helpf.pro
Регистрация
 +3 
Распечатать

1С 8.x : Ввод документа на основании - Программно

Код 1C v 8.х
 НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент();
//Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет
НовДок.Заполнить(ЭлементыФормы.ДокументСписок.ТекущаяСтрока);
НовДок.ПолучитьФорму().Открыть();


//Пример модуля документа ПеречислениеНДФЛвБюджет
Процедура ОбработкаЗаполнения(Основание)
Если ТипЗнч(Основание) = Тип("ДокументСсылка.ЗарплатаКВыплатеОрганизаций") Тогда
// Заполнение шапки
Комментарий = Основание.Комментарий;
КраткийСоставДокумента = Основание.КраткийСоставДокумента;
Организация = Основание.Организация;
Ответственный = Основание.Ответственный;
ДатаПлатежа = Основание.ПериодРегистрации;
МесяцНалоговогоПериода = Основание.ПериодРегистрации;
Для Каждого ТекСтрокаЗарплата Из Основание.Зарплата Цикл
НоваяСтрока = СотрудникиОрганизации.Добавить();
НоваяСтрока.Сумма = ТекСтрокаЗарплата.Сумма;
НоваяСтрока.ФизЛицо = ТекСтрокаЗарплата.Физлицо;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 15983
 +3 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Ввод данных по командировкам в программе ЗУП 0
Ввод сведений о командировках в программе 1С: Зарплата и управление персоналом 8 (ред.30) осуществляется в Разделе Кадры - Все кадровые документы - Создать - Командировка Откроется документ: Ввод сведений о...
Вывод колонтитулов программно ВерхнийКолонтитул, НижнийКолонтитул 5
Колонтитул является специальным текстом, выводимым вверху или внизу каждой страницы при выводе документа на печать. В тексте колонтитула можно использовать следующие управляющие конструкции: > ( >) - при печати в...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.