helpf.pro
Регистрация
 +1 
Распечатать

1С 8.x : Обмен между базами через XML (создается ФабрикаXDTO)

В процедурах выгрузки/загрузки создается ФабрикаXDTO из схемы, которая хранится в макете как файл. Файл настроек схемы надо использовать один и тот же в обработках Загрузки/Выгрузки
Из Фабрики создается объект, его заполняю выгружаемыми данными
Фабрику сохраняю в XML. В процедуре загрузки из читаю фабрику из XML и пробегаю по объектам
Очень удобно!

Код 1C v 8.х
 Функция СоздатьФайлСхемы()

ФайлСхемы = Новый Файл(КаталогВременныхФайлов() + "schema.xsd");
Если ФайлСхемы.Существует() Тогда
УдалитьФайлы(ФайлСхемы.ПолноеИмя);
КонецЕсли;

Ссылка = ПолучитьМакет("schema_xsd");
Ссылка.Записать(ФайлСхемы.ПолноеИмя);

Возврат ФайлСхемы.ПолноеИмя;

КонецФункции

Функция ВыгрузитьДокументы()

ФайлыXSD = Новый Массив();
ФайлыXSD.Добавить(СоздатьФайлСхемы());
Фабрика = СоздатьФабрикуXDTO(ФайлыXSD);

ФайлОбмена = Фабрика.Создать(Фабрика.Тип("http://anton.fly7.ru", "ФайлОбмена"));

Пока Выборка.Следующий() Цикл

Документ = Фабрика.Создать(Фабрика.Тип("http://anton.fly7.ru", "Документ"));
Документ.ID = Строка(Док.УникальныйИдентификатор());
Документ.ВидДокумента = Док.Метаданные().Имя;
Документ.Дата = Док.Дата;
Документ.Номер = Док.Номер;
Документ.Статус = ?(Док.Проведен, "Проведен", ?(Док.ПометкаУдаления, "ПометкаУдаления", "НеПроведен"));
Документ.Комментарий = Док.Комментарий;

КонецЦикла

ПараметрыЗаписиXML = Новый ПараметрыЗаписиXML("UTF-8", "1.0", Ложь);

МойXML = Новый ЗаписьXML;
МойXML.ОткрытьФайл(ИмяФайла, ПараметрыЗаписиXML);
МойXML.ЗаписатьОбъявлениеXML();
Фабрика.ЗаписатьXML(МойXML, ФайлОбмена);
МойXML.Закрыть();

ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Создан файл обмена " + ИмяФайла);

КонецФункции

Процедура ЗагрузитьДокументы()

ФайлыXSD = Новый Массив();
ФайлыXSD.Добавить(СоздатьФайлСхемы());
Фабрика = СоздатьФабрикуXDTO(ФайлыXSD);

ФайлОбмена = Фабрика.Создать(Фабрика.Тип("http://anton.fly7.ru", "ФайлОбмена"));

ОбменXML = Новый ЧтениеXML;
ОбменXML.ОткрытьФайл(ИмяФайла);
ФайлОбмена = Фабрика.ПрочитатьXML(ОбменXML, Фабрика.Тип("http://anton.fly7.ru", "ФайлОбмена"));

Для Каждого Документ Из ФайлОбмена.Документ Цикл

ОбработкаПрерыванияПользователя();

Если Документ.ВидДокумента = "ПоступлениеТоваров" И
ЗначениеЗаполнено(Поставщик) И
Документ.Контрагент.ИНН Поставщик.ИНН Тогда

КонецЕсли;

КонецЦикла

ФайлОбмена = "";
ОбменXML.Закрыть();
УдалитьФайлы(ИмяФайла);

КонецПроцедуры

Файл схемы примерно такой (разукрашка съела скобки, но смысл должен быть понятен ))
Код
xs:schema xmlns:tns="http://anton.fly7.ru" xmlns:xs="http://www.w3.org/2001/XMLSchema" targetNamespace="http://anton.fly7.ru" attributeFormDefault="unqualified" elementFormDefault="qualified">

xs:complexType name="ФайлОбмена">
xs:sequence>
xs:element name="Документ" type="tns:Документ" nillable="true" maxOccurs="unbounded"/>
xs:sequence>
xs:complexType>

xs:complexType name="Документ">
xs:sequence>
xs:element name="ID" type="xs:string"/>
xs:element name="ВидДокумента" type="xs:string"/>
xs:element name="Статус" type="xs:string"/>
xs:element name="Дата" type="xs:dateTime"/>
xs:element name="Номер" type="xs:string"/>
xs:element name="Контрагент" type="tns:Контрагент"/>
xs:element name="Свойства" type="tns:ТаблицаСвойства" nillable="true" minOccurs="0"/>
xs:sequence>
xs:complexType>

xs:complexType name="Контрагент">
xs:sequence>
xs:element name="ID" type="xs:string"/>
xs:element name="Наименование" type="xs:string"/>
xs:element name="ИНН" type="xs:string"/>
xs:sequence>
xs:complexType>

xs:complexType name="ТаблицаСвойства">
xs:sequence>
xs:element name="СтрокаСвойства" type="tns:СтрокаСвойство" nillable="true" maxOccurs="unbounded"/>
xs:sequence>
xs:complexType>

xs:complexType name="СтрокаСвойство">
xs:sequence>
xs:element name="Наименование" type="xs:string" nillable="true"/>
xs:element name="Значение" type="xs:string" nillable="true"/>
xs:sequence>
xs:complexType>

xs:schema>

Автор: Абазин Антон
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 10210
 +1 
Распечатать
Возможно, вас также заинтересует
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное...
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 1
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.