helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Получение текста web-страницы используя HTTPСоединение

Код 1C v 8.х
 //На прямую
Сервер = "w1c.ru";
Соединение = Новый HTTPСоединение(Сервер);
Заголовки = Новый Соответствие;
Заголовки.Вставить("host", Сервер);
Запрос = Новый HTTPЗапрос("/work.html", Заголовки);
Ответ =Соединение.Получить(Запрос);
Если Ответ.КодСостояния = 200 Тогда // Данные получены, обрабатываем их
ТекстСтраницы= Ответ.ПолучитьТелоКакСтроку();
//Выведем тест полученной страницы
Сообщить(ТекстСтраницы);
КонецЕсли;


Код 1C v 8.х
 	// ЧЕРЕЗ ФАЙЛ
Сервер = "w1c.ru";
НТТР = Новый HTTPСоединение(Сервер);
врФайл = КаталогВременныхФайлов()+"pr_"+Формат(ТекущаяДата(), "ДФ=ddMMyyhhmmss")+".txt";
Ответ = НТТР.Получить("/work.html", врФайл);
Если Ответ.КодСостояния = 200 Тогда // Данные получены, обрабатываем их
//Выведем тест полученной страницы
ВходящийФайл = Новый Файл(врФайл);
//Сообщить(ВходящийФайл.Размер());
Текст = Новый ТекстовыйДокумент;
Текст.Прочитать(врФайл,КодировкаТекста.UTF8);
Для н=1 По Текст.КоличествоСтрок()Цикл
стр=Текст.ПолучитьСтроку(н);
//Выводим текст страницы построчно
Сообщить(стр);
КонецЦикла;
КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9706
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая выгрузка загрузка данных используя регламентное задание 1
Для обмена данными между программами необходимо сделать следующее: 1. При помощи Конвертации Данных создать правила выгрузки данных 2. Нужно чтобы в конфигурации была обработка УниверсальныйОбменДаннымиXML ,...
Внутренняя ошибка компоненты DBENG8 0
Ошибка СУБД: Внутренняя ошибка компоненты dbeng8 по причине: Внутренняя ошибка компоненты dbeng8 Решение: 1: Тестирование исправление базы 2: Проверка базы используя chdbfl.exe 3: Обновить версию Платформы 4: Обновить dbeng8.dll...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.