helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Форма ~ Работа со стандартным периодом

Код 1C v 8.х
 Диалог = Новый ДиалогРедактированияСтандартногоПериода();
ПеременнаяТипаСтандартныйПериод = Новый СтандартныйПериод();
Диалог.Период = ПеременнаяТипаСтандартныйПериод;
Если Диалог.Редактировать() Тогда
ПеременнаяТипаСтандартныйПериод = Диалог.Период;
КонецЕсли;
Запрос.УстановитьПараметр("ДатаНачала", ПеременнаяТипаСтандартныйПериод.ДатаНачала);
Запрос.УстановитьПараметр("ДатаОкончания", ПеременнаяТипаСтандартныйПериод.ДатаОкончания);


Код 1C v 8.х
 НП = Новый НастройкаПериода	;
НП.ВариантНастройки=ВариантНастройкиПериода.Интервал;
НП.ВариантНачала=ВариантГраницыИнтервала.КонкретнаяДата;
НП.ВариантОкончания=ВариантГраницыИнтервала.КонкретнаяДата;

НП.ДатаНачала=ДатаНачала;
НП.ДатаОкончания=ДатаОкончания;
Если НП.Редактировать()Тогда
ДатаНачала=НП.ПолучитьДатуНачала();
ДатаОкончания= НП.ПолучитьДатуОкончания();
КонецЕсли;

Если ДатаОкончания=Дата('00010101') Тогда
ДатаОкончания=ТекущаяДата();
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6411
 0 
Распечатать
Возможно, вас также заинтересует
Использование ASCII кодов в 1С 2
Хотите писать в 1С не только стандартными буквами, знаками изображенными на клавиатуре и вставлять опять же стандартные смайлики, а тем не менее существует возможность ставить дополнительные символы, так же можно...
Как выполнить перепроведение документов стандартными инструментами 1С? 1
При работе, часто бывает нужно перепровести разом документы за месяц. Удивительно, но многие не знают что есть встроенный механизм проведения: Откройте Операции - проведение документов И в открывшемся окне: 1....
Как поменять период у записей периодического независимого регистра, соответствующих ряду условий? 0
В периодическом независимом регистре сведений ОтветственныеЛицаОрганизации все записи, касающиеся организации с наименованием Групп-трейдинг, период которых меньше 01 января 2005 года, необходимо перенести на 01...
Как сделать резервную копию информационной базы 1С? 1
Сделай архив и спи спокойно! И это факт - ведь порой совсем неожиданно, рано или поздно из строя выйдет даже самый дорогой и стабильный компьютер, а в нем все Ваши данные которые вы вводите в 1С:Предприятие ежедневно:...
Как сформировать сторно-запись регистра расчета, Метод «ПолучитьДополнение() 1
Сторно-записи, «прикрывающие» фактический период действия вводимой записи с более поздним периодом регистрации, могут быть сформированы вручную стандартными методами формирования записей регистра расчета. В этом...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.