helpf.pro
Регистрация
 +3 
Распечатать

1С 8.x : Оформление строки в ПриПолученииДанных или ПриВыводеСтроки

Событие ПриПолученииДанных использется для оформления ячеек строк данных, отображаемых табличным полем. Обработчик данного события вызывается табличным полем в тех же случаях, что и обработчик ПриВыводеСтроки, т.е. при обновлении данных, отображаемых табличным полем или при поиске по подстроке. Важно отметить, что обработчик данного события вызывается табличным полем перед вызовом обработчиков события ПриВыводеСтроки для всех видимых строк табличного поля. Основным отличием данного события от события ПриВыводеСтроки является то, что в обработчике события ПриПолученииДанных можно изменять настройки ячеек группы строк, а не одной строки как в обработчике события ПриВыводеСтроки.

Обрабатывая данное событие можно изменять шрифт, цвет фона или текста, как определенной ячейки, так и всей строки табличного поля, устанавливать высоту или видимость ячеек строки табличного поля, а также устанавливать картинку, флажок или новый текст в ячейке. Параметром данного события является объект типа ОформлениеСтрок - коллекция объектов типа ОформлениеСтроки, являющихся оформлениями строк табличного поля.

Пример кода:

Код 1C v 8.х
 Процедура ТППриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

Попытка
ОформлениеСтроки.Ячейки.ПредоплатаОтсрочка.УстановитьТекст(?(ОформлениеСтроки.ДанныеСтроки.Ссылка.Счет.ДоговорКонтрагента.КонтролироватьЧислоДнейЗадолженности, "ОТСРОЧКА","ПРЕДОПЛАТА"));
Исключение
КонецПопытки;

Если ОформлениеСтроки.Ячейки.Доставка.Значение = Неопределено Тогда
возврат;
КонецЕсли;

Если ДанныеСтроки.Доставка.Проведен Тогда
ОформлениеСтроки.Ячейки.Картинка.ИндексКартинки = 0;
ИначеЕсли ДанныеСтроки.Доставка.ПометкаУдаления Тогда
ОформлениеСтроки.Ячейки.Картинка.ИндексКартинки = 1;
Иначе
ОформлениеСтроки.Ячейки.Картинка.ИндексКартинки = 2;
КонецЕсли;
ОформлениеСтроки.Ячейки.Картинка.ОтображатьКартинку = истина;

Если ДанныеСтроки.СтатусНов = "Нет машины" Тогда 
ОформлениеСтроки.Ячейки.СтатусНов.ЦветФона = Новый Цвет(255, 196, 196);
ИначеЕсли ДанныеСтроки.СтатусНов = "Нет разрешения" Тогда
текцвет = Новый Цвет(255, 196, 196);
Если ДанныеСтроки.Доставка.ДатаДоставки = НачалоДня(РабочаяДата) Тогда
ТекВремя = Дата(1,1,1)+(ТекущаяДата()-НачалоДня(ТекущаяДата()));
Попытка ПодачаМашины=?(ДанныеСтроки.Доставка.ВремяЗагрузкиФакт[0].ПодачаМашины>ДанныеСтроки.Доставка.ВремяПриездаЭкспедитораФакт,ДанныеСтроки.Доставка.ВремяЗагрузкиФакт[0].ПодачаМашины,ДанныеСтроки.Доставка.ВремяПриездаЭкспедитораФакт); Исключение ПодачаМашины = ДанныеСтроки.Доставка.ВремяПриездаЭкспедитораФакт; КонецПопытки;
Если ПодачаМашины+(15*60)> ТекВремя Тогда ОформлениеСтроки.Ячейки.СтатусНов.УстановитьТекст("Получение разрешения"); текцвет = Новый Цвет(255, 225, 225); КонецЕсли;
КонецЕсли;
ОформлениеСтроки.Ячейки.СтатусНов.ЦветФона = текцвет;
ИначеЕсли ДанныеСтроки.СтатусНов = "Загрузка" Тогда 
ОформлениеСтроки.Ячейки.СтатусНов.ЦветФона = Новый Цвет(255, 153, 0);
ИначеЕсли ДанныеСтроки.СтатусНов = "В пути" Тогда 
ОформлениеСтроки.Ячейки.СтатусНов.ЦветФона = Новый Цвет(255, 255, 0);
ИначеЕсли ДанныеСтроки.СтатусНов = "На объекте" Тогда 
ОформлениеСтроки.Ячейки.СтатусНов.ЦветФона = Новый Цвет(51, 204, 204);
ИначеЕсли ДанныеСтроки.СтатусНов = "Завершено" Тогда 
ОформлениеСтроки.Ячейки.СтатусНов.ЦветФона = Новый Цвет(137, 255, 113);
КонецЕсли;

Если ЗначениеЗаполнено(ДанныеСтроки.СтатусSMS) Тогда

Если ДанныеСтроки.СтатусSMS = "Доставлено" Тогда 
ОформлениеСтроки.Ячейки.СтатусSMS.ЦветФона = Новый Цвет(137, 255, 113);
ИначеЕсли ДанныеСтроки.СтатусSMS = "Поставлено в очередь" ИЛИ
ДанныеСтроки.СтатусSMS = "Отправляется" ИЛИ
ДанныеСтроки.СтатусSMS = "Отправлено" Тогда 
ОформлениеСтроки.Ячейки.СтатусSMS.ЦветФона = Новый Цвет(255, 255, 0);
Иначе 
ОформлениеСтроки.Ячейки.СтатусSMS.ЦветФона = Новый Цвет(255, 0, 0);
КонецЕсли;

КонецЕсли; 

ОформлениеСтроки.Ячейки.колКОтгрузке.УстановитьТекст(ДанныеСтроки.колКОтгрузке);
Если ДанныеСтроки.колКОтгрузке = "ОК" Тогда
ОформлениеСтроки.Ячейки.колКОтгрузке.ЦветФона = Новый Цвет(200, 255, 200);
Иначе
ОформлениеСтроки.Ячейки.колКОтгрузке.ЦветФона = Новый Цвет(255, 0, 0);
КонецЕсли;

ОформлениеСтроки.Ячейки.колСДоставки.УстановитьТекст(ДанныеСтроки.колСДоставки);
Если ДанныеСтроки.колСДоставки = "ОК" Тогда
ОформлениеСтроки.Ячейки.колСДоставки.ЦветФона = Новый Цвет(200, 255, 200);
Иначе
ОформлениеСтроки.Ячейки.колСДоставки.ЦветФона = Новый Цвет(255, 0,0);
КонецЕсли;

//Доставка до 14.00 раскраска цветом
Если НЕ (ДанныеСтроки.Доставка.ВидДоставки = Перечисления.ВидыДоставки.Самовывоз или ДанныеСтроки.Доставка.ВидДоставки = Перечисления.ВидыДоставки.Централизация) Тогда
Если ДанныеСтроки.Доставка.Дата < НачалоДня(ДанныеСтроки.Доставка.Дата)+60*60*14 Тогда ОформлениеСтроки.Ячейки.Менеджер.ЦветФона = Новый Цвет(166, 255, 166); Иначе ОформлениеСтроки.Ячейки.Менеджер.ЦветФона = Новый Цвет(255, 166,166); КонецЕсли;
КонецЕсли;

КонецПроцедуры

А вот так это выглядит в реальности:

Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 11964
 +3 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Ввод дополнительного ежегодного отпуска 0
Вид расчета, используемый для начисления оплаты дополнительного ежегодного отпуска , описывается в плане видов расчета Основные начисления организаций . Новый вид расчета удобнее создать копированием...
Документ "Корректировка записей регистров" - Как программно создать и заполнить? 2
Документ «Корректировка записей регистров» в типовых конфигурациях 1С предназначен для ручной корректировки записей регистров накопления, зависимых регистров сведений и регистров бухгалтерии. Типичные ситуации, в...
Журнал регистрации 0
Журнал регистрации относится к информационной базе и служит для сохранения информации о событиях, возникающих в процессе работы пользователей с данной информационной базой . Эта информация может быть важной с...
Загрузить данные в 1с из текстового файла с разделителями 1
В этой статье я расскажу, как загружать данные в 1с 8 из простейших текстовых файлов с разделителями. Обычно они имеют расширение csv (Comma-Separated Values). Т. е. название подразумевает, что в каждой строке такого текстового файла...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.