helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Табличная часть ~ Как программно отловить изменение отбора строк?

Иногда, при установке отбора строк табличного поля необходимо выполнить какие-либо действия - но как это отловить!?

решение ниже:

Код 1C v 8.х
 Процедура ПриОткрытии()

ПодключитьОбработчикИзмененияДанных("ЭлементыФормы.ТабличнаяЧасть1.Отбор", "ПриИзмененииОтбора", Истина);

КонецПроцедуры


Процедура ПриИзмененииОтбора(ПутьКДанным)

Сообщить("Изменился отбор - " + ПутьКДанным);

КонецПроцедуры 
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 5843
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.