helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как программно создать документ копированием?

При доработке какого-либо процесса, бывает необходимо программно создать документ копированием по ссылке уже созданного в базе.

Код позволяющий создать документ копированием:

Код 1C v 8.х
 Процедура ДействияФормыДобавитьКопированием(Кнопка)
колдок = 5;
Если ВвестиЧисло(колдок,"Сколько создать?") Тогда
Для н=1 по колдок Цикл 
// Копирование документа
ДокументКопия = ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока.Скопировать();  
ДокументКопия.Дата = РабочаяДата;                                        
ДокументКопия.Записать();
КонецЦикла;
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 8878
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.