helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как проверить записан ли документ?

Перед обработкой документа необходимо проверить - записан ли документ? если Да - обработать, нет -вывести предупреждение!

Ниже код позволяющий проверить записан ли только что созданные документ:

В Такси и вообще управляемом приложении проверяется ссылка: Объект.Ссылка.Пустая()

Код 1C v 8.3
 // в Управляемом приложении
&НаКлиенте
Процедура ОбработатьДок(Отказ)
         Если не ЗначениеЗаполнено(Объект.Ссылка) тогда
            Отказ=Истина; //Докум еще не записан, т.к. ссылки нет         
    КонецЕсли;
КонецПроцедуры 
Код 1C v 8.х
 // В Обычных формах
Если ЭтоНовый() Тогда
Предупреждение("Документ должен быть записан!");
Иначе
// обрабатываем
КонецЕсли;

код, позволяющий проверить признак модифицированности ранее созданного документа:

Код 1C v 8.2 УП
 Если ЭтотОбъект.Модифицированность() Тогда
      
        Предупреждение("Документ был изменен. Для обработки его нужно записать.");
        Возврат Неопределено;     
      
    КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 9887
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 3
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.