helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция ЗначениеЗаполнено(Значение) для 8.0

В 8.1 есть такая встроенная функция, а в 8.0 про нее почему-то забыли, исправим это недоразумение:

Код 1C v 8.х
 
Функция ЗначениеЗаполнено(Значение) Экспорт
Результат = Истина;
ТипЗначения = ТипЗнч(Значение);

Если Значение = Неопределено Тогда
Результат = Ложь;
ИначеЕсли Значение = NULL Тогда
Результат = Ложь;
ИначеЕсли ТипЗначения = Тип( "Строка" ) Тогда
Если СокрЛП( Значение ) = "" Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Число" ) Тогда
Если Значение = 0 Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Дата" ) Тогда
Если Значение = Дата( '00010101' ) Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Булево" ) Тогда
Результат = Истина;
ИначеЕсли ТипЗначения = Тип( "РежимПроведенияДокумента" ) Тогда
Результат = Истина;
Иначе
Если Значение = Новый( ТипЗначения ) Тогда
Результат = Ложь;
КонецЕсли;
КонецЕсли;
Возврат Результат;
КонецФункции

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8006
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.