helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как удалить дубли в списке значений

Если Вам необходимо почистить список значений от повторяющихся записей, используйте следующий код:

Код 1C v 8.х
 структошибок = Новый СписокЗначений;
//....
// заполнение списка значений
//....
//список значений в массив
Массив=структошибок.ВыгрузитьЗначения();
//Удаляем дубли из массива
ТекущийИндекс = 0; 
ВсегоЭлементов = Массив.Количество(); 
Пока ТекущийИндекс < ВсегоЭлементов Цикл 
Индекс2 = ТекущийИндекс + 1; 
Пока Индекс2 < ВсегоЭлементов Цикл 
Если Массив[Индекс2] = Массив[ТекущийИндекс] Тогда 
Массив.Удалить(Индекс2); 
ВсегоЭлементов = ВсегоЭлементов - 1; 
Иначе 
Индекс2 = Индекс2 + 1; 
КонецЕсли; 
КонецЦикла; 
ТекущийИндекс = ТекущийИндекс + 1; 
КонецЦикла; 

//Выведем результат
Для Каждого спстр из Массив цикл
Сообщить(спстр);
КонецЦикла;
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 2740
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.