helpf.pro
Регистрация
 +1 
Распечатать

1С 8.x : Как в отобразить картинку в табличной части

В табличной части есть документы заявки от покупателя, нам нужно добавить картинку для отображения статуса документов заявка - проведен , не проведен, помечен на удаление.

Код 1C v 8.х
 
//Отобразим картинку 
Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

Элемент.Колонки.Картинка.КартинкиСтрок = БиблиотекаКартинок.СостоянияДокумента;

Если ДанныеСтроки.ДокументЗаявка.Проведен = Истина Тогда

ОформлениеСтроки.Ячейки.Картинка.ОтображатьКартинку = Истина;
     ОформлениеСтроки.Ячейки.Картинка.ИндексКартинки=0;
 
ИначеЕсли ДанныеСтроки.ДокументЗаявка.ПометкаУдаления = Истина Тогда

ОформлениеСтроки.Ячейки.Картинка.ОтображатьКартинку = Истина;
     ОформлениеСтроки.Ячейки.Картинка.ИндексКартинки=1;
 
ИначеЕсли ДанныеСтроки.ДокументЗаявка.Проведен = Ложь Тогда

ОформлениеСтроки.Ячейки.Картинка.ОтображатьКартинку = Истина;
     ОформлениеСтроки.Ячейки.Картинка.ИндексКартинки=2;

КонецЕсли;

КонецПроцедуры


Разместил:   Версии: | 8.x |  Дата:   Прочитано: 1013
 +1 
Распечатать
Возможно, вас также заинтересует
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное...
В этом периоде очередность проведения не контролировалась 0
Контролировать или нет выбирается в: Сервис - Настройка программы - Контроль проведения Если галка не стоит, то Установить - ОК Если галка уже стоит, то ее Снять - ОК, зайти снова и Установить - ОК
Ввести дату, ввод даты 1
ДатаНапоминания = РабочаяДата; Подсказка = "Введите дату и время"; ЧастьДаты = ЧастиДаты.ДатаВремя; Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда // обработка даты напоминания КонецЕсли Если...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.