helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : У текущего пользователя нет ролей, допускающих запуск информационной базы!

В стандартных конфигурациях есть такая проверка, например :
В ЗУПе у пользователя должна быть доступна роль "Пользователь" или "ПолныеПрава"
В Бухгалтерии у пользователя должна быть доступна роль "Бухгалтер" или "ПолныеПрава"

А проверяет это кусок кода вида:
Код 1C v 8.х
 
// Функция проверяет установлены ли у пользователя роли,
// с которыми можно запускать конфигурацию
Функция ЕстьДоступныеПраваДляЗапускаКонфигурации() Экспорт

Возврат РольДоступна("ПолныеПрава")
ИЛИ РольДоступна("Пользователь")
ИЛИ ЕстьРолиБезОграниченияПравДоступаНаУровнеЗаписей();

КонецФункции

//.....
// а ниже
Если НЕ ЕстьДоступныеПраваДляЗапускаКонфигурации() Тогда
Отказ = Истина;
#Если Клиент Тогда
Предупреждение("У текущего пользователя нет ролей, допускающих запуск информационной базы!", 10, "Недостаточно прав доступа");
#КонецЕсли
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 11715
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.