helpf.pro
Регистрация
 +2 
Распечатать

1С 8.x : Функция преобразовавает Фамилия Имя Отчество в Фамилия И. О.

Код 1C v 8.х
 
Функция ФамилияИО(ПолнИмя) Экспорт
ПервПроб = Найти(ПолнИмя," ");
Если ПервПроб=0 Тогда
Возврат ПолнИмя;
Иначе
Фамилия = Лев(ПолнИмя,ПервПроб);
ИО = Сред(ПолнИмя,ПервПроб+1);
ИО = СокрЛ(ИО);
Имя = Лев(ИО,1)+".";
ВтПроб = Найти(ИО," ");
Если ВтПроб=0 Тогда
Возврат Фамилия+Имя;
Иначе
Возврат Фамилия+Имя+" "+Лев(СокрЛ(Сред(ИО,ВтПроб+1)),1)+".";
КонецЕсли;
КонецЕсли;
КонецФункции

//Пример обращения
Текст = "Андреева Алла Александровна";
Сообщить(ФамилияИО(Текст)); //Выведет - Андреева А. А.


Код 1C v 8.х
 Функция ИОФамилия(Сотрудник) Экспорт
Пока Найти(Сотрудник, " ") <> 0 Цикл
Сотрудник = СтрЗаменить(Сотрудник," "," ");
КонецЦикла;

Сотрудник = СтрЗаменить(Сотрудник," ",Символы.ПС);
Возврат Лев(СтрПолучитьСтроку(Сотрудник,2),1) + ". "+Лев(СтрПолучитьСтроку(Сотрудник,3),1) + ". "+СтрПолучитьСтроку(Сотрудник,1);
КонецФункции


Код 1C v 7.x
 Функция ФамилияИО(ПолнИмя) Экспорт
// позиция первого пробела
ПервПроб = Найти(ПолнИмя," ");
Если ПервПроб=0 Тогда
Возврат ПолнИмя;
Иначе
Фамилия = Лев(ПолнИмя,ПервПроб);
ИО = Сред(ПолнИмя,ПервПроб+1);
ИО = СокрЛ(ИО);
Имя = Лев(ИО,1)+".";
// позиция второго пробела
ВтПроб = Найти(ИО," ");
Если ВтПроб=0 Тогда
Возврат Фамилия+Имя;
Иначе
Возврат Фамилия+Имя+" "+Лев(СокрЛ(Сред(ИО,ВтПроб+1)),1)+".";
КонецЕсли;
КонецЕсли;
КонецФункции


Существует запрет на коноплю из-за политического и социального давления, его терпимость. Но можно семена конопли купить - в последнее время, ее декриминализацию стали продвигать ради для рекреационного и медицинского использования.
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 38724
 +2 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 24
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через терминал, а еще у нее свой ноутбук и
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 51
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
1C медленно работает по сети с базой на SQL Server 22
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для взаимодействия 1С с SQL Server. П
1С Предприятие что это? 12
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который выпускает компания 1С . Что такое
Cклонения по падежам 6
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.