helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Использование генератора случайных чисел - Random

Генератор случайных чисел инициализируется начальным числом из параметра:

Код 1C v 8.х
 НачальноеЧисло = 167;
ГСЧ = Новый ГенераторСлучайныхЧисел(НачальноеЧисло);
СлучайноеЧисло = ГСЧ.СлучайноеЧисло(0, 1000);


Последовательность случайных чисел для одного и того же начального числа будет одинакова.
При создании генератора случайных чисел можно не передавать ему начальное число. В этом случае он инициализируется временем работы операционной системы с момента старта.
Код 1C v 8.х
 ГСЧ = Новый ГенераторСлучайныхЧисел();
СлучайноеЧисло = ГСЧ.СлучайноеЧисло(0, 1000);


Еще примеры самодельных функций:
Код 1C v 8.х
 Функция Рандом() Экспорт
UID=Новый УникальныйИдентификатор();
UID = СтрЗаменить(UID,"-","");
Значение = "";
Для Н=1 По СтрДлина(UID) Цикл
Симв = Сред(UID,Н,1);
Значение = Значение+Прав(КодСимвола(Симв),1);
КонецЦикла;
Возврат Число("0."+Значение);
КонецФункции

Код 1C v 8.х
 Функция Ранд(Парам=0)
Если Парам<>0 Тогда
Случай=Парам;
КонецЕсли;
Если Число(Случай)=0 Тогда
Случай=Число(СтрЗаменить(""+ТекущееВремя(),":",""));
Случай=(16807*Случай)%2147483647;
КонецЕсли;
Случай=(16807*Случай)%2147483647;
Случай=макс(Случай,-Случай);
Возврат(Случай/2147483647);
КонецФункции



Для 7.7 можно использовать генератор случайностей
Код 1C v 7.x
 ремоте=СоздатьОбъект("rcbdyctl.setting");
Сообщить(ремоте.CreatePassword);
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 16419
 0 
Распечатать
Возможно, вас также заинтересует
Использование ASCII кодов в 1С 2
Хотите писать в 1С не только стандартными буквами, знаками изображенными на клавиатуре и вставлять опять же стандартные смайлики, а тем не менее существует возможность ставить дополнительные символы, так же можно...
Как получить количество ЛЕТ, МЕСЯЦЕВ, ДНЕЙ между датами? 1
Нужно получить разницу между датами 31.12.2009 и 10.01.2005 и отобразить ее как: 4 года 11 месяцев 21 день Процедура ТЕСТ_ВыполнитьНажатие(Кнопка) ДатаНач = Дата(2009, 12, 31); ДатаКон = Дата(2005, 1, 10); Лет=0; Мес=0; Дн=0; ...
Как связать 1C, PHP , MySQL? 2
В современном мире люди используют Интернет не только для поиска информации, но и для приобретения каких либо товаров и услуг. Поэтому организации, например имеющие статус среднего бизнеса, стараются разместить свои...
Как сделать чтобы при выделении числе в табличном документе, отчете выводилась их сумма? 0
Часто бывает необходимость сложить несколько чисел в печатной форме, например, как это сделано в Excel. Сегодня решить посмотреть Бухгалтерию КОРП. Нашел в ней очень интересную штуку: поле в котором показан результат...
Как сделать чтобы при редактировании в ячейке появлялся калькулятор? 0
Необходимо чтобы в режиме 1С Предприятия при редактировании ячейки табличного документа появлялся калькулятор для ввода чисел: https://helpf.pro/uploads/img/_1-68ZdLYVaUw.png Для это в свойствах ячейки необходимо указать: - Снять...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.