helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Пример выгрузки данных в Текстовый файл, документ

Код 1C v 8.х
 Режим = РежимДиалогаВыбораФайла.Сохранение; 
ДиалогСохраненияФайла = Новый ДиалогВыбораФайла(Режим);
ДиалогСохраненияФайла.ПолноеИмяФайла = "Выгрузка_"+Формат(ПериодРегистрации,"ДФ=M_yy");
Фильтр = "Текст(*.txt)|*.txt";
ДиалогСохраненияФайла.Фильтр = Фильтр;
ДиалогСохраненияФайла.МножественныйВыбор = Ложь;
ДиалогСохраненияФайла.Заголовок = "Выберите файл";
Если ДиалогСохраненияФайла.Выбрать() Тогда
ПутьКФайлу = ДиалогСохраненияФайла.ПолноеИмяФайла;
// выбрали файл, сохраняем в него Проводки
ТекДок = Новый ТекстовыйДокумент;
Для Каждого Стр Из Проводки Цикл
Состояние("Выгружаю строку: "+Строка(Стр.НомерСтроки));
ТекДок.ДобавитьСтроку(Строка(стр.СчетДт)+"~"+Строка(стр.СчетКт)+"~"+Строка(стр.Физлицо.Код)+"~"+Формат(стр.СуммаВыгр,"ЧГ=0"));
КонецЦикла;
КонецЕсли;
ТекДок.Записать(ПутьКФайлу);


В результате получается файл вида:
70~76.95~000000056~888,64
70~76.95~000000127~2938,18
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 11470
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.