helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Проверка контрагентов на задвоение по ИНН при вводе

В 7.7 Откройте Справочник Контрагенты - Форма Элемента, двойным щелчком по полю ИНН, на закладке Дополнительно в поле формула введите ПроверкаИНН()
И в Модуль добавьте процедуру ПроверкаИНН()
Код 1C v 7.x
 Процедура ПроверкаИНН() 
СпрКонтрагенты = СоздатьОбъект("Справочник.Контрагенты");
Если СпрКонтрагенты.НайтиПоРеквизиту("ИНН",ИНН,1) = 1 Тогда
Предупреждение("Найден контрагент с таким же ИНН :"+РазделительСтрок+Строка(СпрКонтрагенты.Код)+" - "+Строка(СпрКонтрагенты));
КонецЕсли;
КонецПроцедуры


В 8- ой версии, откройте Справочник Контрагенты - Форму Элемента, двойным щелчком по полю ИНН, в событиях ПриИзменении введите ПроверкаИНН()
И в Модуль добавьте процедуру ПроверкаИНН()
Код 1C v 8.х
 Процедура ПроверкаИНН() 
СпрКонтрагенты = Справочники.Контрагенты;
Если СпрКонтрагенты.НайтиПоРеквизиту("ИНН",ИНН) Тогда
Предупреждение("Найден контрагент с таким же ИНН :"+РазделительСтрок+Строка(СпрКонтрагенты.Код)+" - "+Строка(СпрКонтрагенты));
КонецЕсли;
КонецПроцедуры


Теперь при вводе ИНН происходит проверка, если Контрагент с таким ИНН уже есть в базе, то выдается Предупреждение!

Код 1C v 8.2 УП
 СпрКонтрагенты = Справочники.Контрагенты.НайтиПоРеквизиту("ИНН",Запись.ИНН);
Если Не СпрКонтрагенты=Справочники.Контрагенты.ПустаяСсылка() Тогда
Предупреждение("Найден контрагент с таким же ИНН : "+Строка(СпрКонтрагенты.Код)+" - "+Строка(СпрКонтрагенты));
КонецЕсли;
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 17359
 0 
Распечатать
Возможно, вас также заинтересует
COM-соединение не обнаружило свободной лицензии / ключ защиты 0
Иногда при подключении к 1С возникает ошибка: COM-соединение не обнаружило свободной лицензии! COM-соединение не обнаружило ключ защиты программы! https://helpf.pro/uploads/img/_1-UsuyAg6E2P.jpg В таких случаях, иногда, может помочь...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Загрузка данных в 1С из PDF 1
В данной статье описан пример реализации загрузки данных накладных из PDF файлов для одного крупного Ритейла... И так у Нас есть несколько файлов в формате pdf, которые нам необходимо загрузить в 1С. Чтение PDF файлов из...
Использование Web-сервисов для синхронизации баз данных в режиме online 1с 8.х 7
Часто при ведении учета в различных конфигурациях 1с возникает необходимость выполнения обмена данных. Для решения этой задачи принято использовать Универсальный обмен данными XML или другие внешние обработки, общим...
Как загрузить данные из Access в 1С ? 2
Загружаем данные из Access в 1С Файл = " C:filesdemo.mdb" ; //СтрокаПодключения = " Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" + Файл + " ; Extended Properties=" " Excel 8.0;HDR=NO;" " " ; СтрокаПодключения = " Provider=Microsoft.Jet
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.