helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Проведение выбранных документов, отмена проведения выбранных документов

Код 1C v 8.х
 Процедура Провести(Кнопка)
ВыборкаДокументов = Документы.НДФЛиЕСНДоходыИНалоги.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл
// Проводим только те документы у которых в комментарии есть "НДФЛ Доходы и удержания"
Если Найти(ВыборкаДокументов.Комментарий, "НДФЛ Доходы и удержания") > 0 Тогда
ТекДок=ВыборкаДокументов.ПолучитьОбъект();
Попытка
ТекДок.Записать(РежимЗаписиДокумента.Проведение);
Сообщить("Проведен документ :" + Строка(ТекДок));
Исключение
Сообщить("Невозможно провести документ("+Строка(ТекДок)+"), т.к.:");
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецЦикла
КонецПроцедуры

Процедура ОтменитьПроведение(Кнопка)
ВыборкаДокументов = Документы.НДФЛиЕСНДоходыИНалоги.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл
Если Найти(ВыборкаДокументов.Комментарий, "НДФЛ Доходы и удержания") > 0 Тогда
ТекДок=ВыборкаДокументов.ПолучитьОбъект();
Попытка
ТекДок.Записать(РежимЗаписиДокумента.ОтменаПроведения);
Сообщить("Отмена проведения документ :" + Строка(ТекДок));
Исключение
Сообщить("Невозможно отменить проведение("+Строка(ТекДок)+"), т.к.:");
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецЦикла
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 9012
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 3
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Ввод данных по командировкам в программе ЗУП 0
Ввод сведений о командировках в программе 1С: Зарплата и управление персоналом 8 (ред.30) осуществляется в Разделе Кадры - Все кадровые документы - Создать - Командировка Откроется документ: Ввод сведений о...
Восстановление партионного учета в УТ 0
Проблема следующая: при выполнении стандартной обработки " проведение по партиям" , непонятно почему, но граница актуальности партионного учета не сдвигается, хотя при перепроведении документов никаких ошибок не...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.