helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция проверяет соответствие ОГРН Контрагента требованиям

ОГРН (основной государственный регистрационный номер) — государственный регистрационный номер записи о создании юридического лица либо записи о первом представлении в соответствии с Федеральным законом “О государственной регистрации юридических лиц” сведений о юридическом лице, зарегистрированном до введения в действие указанного Закона (пункт 8 Правил ведения Единого государственного реестра юридических лиц) (см. ОГРН в Википедии).

Структура ОГРН:

* 1 цифра – код, признак ОГРН (всегда равен 1);
* 2 цифры – две последние цифры года внесения записи в государственный реестр;
* 2 цифры – код региона по перечню регионов в 65-й статье Конституции
* 7 цифр – порядковый номер записи от начала года;
* 1 цифра – проверочный код ОГРН;

Что можно узнать зная ОГРН:

1. Год регистрации организации по двум последним цифрам.

2. С некоторой точностью месяц (а может быть и неделю) регистрации организации по порядковому номеру записи.

3. Код региона организации по 65-й статье Конституции.

4. По коду ОГРН может быть получена иная публичная информациия по организации – ИНН, КПП, наименование, адрес из публичного реестра ФНС.

Можно обратить внимание что ИНН и ОГРН отличаются принципами ведения порядковых номеров организаций. Если в ИНН они привязаны к налоговой инспекции, то в ОГРН к году регистрации. Соответственно исходя из возможности по порядковому номеру ИНН определить дату его присвоения, можно говорить что ИНН несёт чуть больше информации (номер инспекции) чем ОГРН.

Код 1C v 8.х
 // Параметры:
// ОГРН - строка - проверяемый основной государственный регистрационный номер
Функция ОГРНсоответствуетТребованиям(Знач ОГРН) Экспорт
Попытка
ОГРНБезВедущихНулей = Формат(ОГРН,"ЧГ=0");
Исключение
Возврат Ложь;
КонецПопытки;
ОГРН = Строка(ОГРНБезВедущихНулей);
Если СтрДлина(ОГРН) <> 13 Тогда
Возврат Ложь;
Иначе
Возврат Истина;//проверка временно отключена
КонецЕсли;
ОГРН12 = Число(Лев(ОГРН, 12));
Если Прав(Формат(ОГРН12%11, "ЧН=0; ЧГ=0"), 1) = Прав(ОГРН, 1) Тогда
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7820
 0 
Распечатать
Возможно, вас также заинтересует
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Внешние источники данных 0
Почему данная возможность вызывает такой интерес? Любой человек, который программировал в 1С при этом достаточно неплохо знаком с SQL и хотя бы в общих чертах знаком с архитектурой и принципами разработки других...
Выбрать документы за период, установить значение в реквизит табличной части и провести документ 0
// Необходимо выбрать документы за период по ответственному // В каждом документе, где в первой строке табличного поля не заполнен реквизит Статья // заполнить, и провести документ Запрос = Новый Запрос; Запрос.Текст = ...
Вывод результата запроса в табличный документ 0
//Вых - ЭлементыФормы.РезультатТабличныйДокумент, //ТЗЗ - Результат выполнения запроса Процедура ПечатьРезвТаб(Вых,ТЗЗ) Экспорт КоличествоКолонок = ТЗЗ.Колонки.Количество(); Выборка =...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.