helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Пример загрузки остатков в документ 1С из DBF файла

Код 1C v 8.х
 ФайлОстатков = Новый XBase;
ФайлОстатков.Кодировка = КодировкаXBase.OEM;
ФайлОстатков.ОткрытьФайл(ПутьКТаблицеОстатков);
ФайлОстатков.Первая();
Пока Не ФайлОстатков.ВКонце() Цикл
КодКонтрагента = СокрЛП(ФайлОстатков.ПолучитьЗначениеПоля("ZKPO"));
Если КодКонтрагента = "" Тогда
КодКонтрагента = СокрЛП(ФайлОстатков.ПолучитьЗначениеПоля("IDENKOD"));
КонецЕсли;
НаименованиеКонтрагента = СокрЛП(СтрЗаменить(ФайлОстатков.ПолучитьЗначениеПоля("NAME"),"?","і"));
Контрагент = ПолучитьКонтрагента(КодКонтрагента,НаименованиеКонтрагента);
СимволСчета = СокрЛП(ФайлОстатков.ПолучитьЗначениеПоля("SYMBOL"));
ОстатокДебет = ФайлОстатков.ПолучитьЗначениеПоля("DB_PP");
ОстатокКредит = ФайлОстатков.ПолучитьЗначениеПоля("KR_PP");

Документ = Документы.КорректировкаДолга.СоздатьДокумент();
Документ.Организация = Организация;
Документ.Дата = "20090630235959";
Документ.ВидОперации = Перечисления.ВидыОперацийКорректировкаДолга.ВводНачальныхОстатков;
Если ОстатокДебет > 0 Тогда
Документ.КонтрагентДебитор = Контрагент;
Документ.СуммыДолга.Очистить();
СтрокаСуммыДолга = Документ.СуммыДолга.Добавить();
СтрокаСуммыДолга.ВидЗадолженности = Перечисления.ВидыЗадолженности.Дебиторская;
СтрокаСуммыДолга.ДоговорКонтрагента = ПолучитьДоговор(Документ.КонтрагентДебитор);
Если Лев(СимволСчета,3) = "361" Тогда
СтрокаСуммыДолга.ТипКонтрагента = Перечисления.СтатусыКонтрагентов.Покупатель;
Иначе
СтрокаСуммыДолга.ТипКонтрагента = Перечисления.СтатусыКонтрагентов.Поставщик;
КонецЕсли;
СтрокаСуммыДолга.КратностьВзаиморасчетов = 1.00;
СтрокаСуммыДолга.КурсВзаиморасчетов = 1.00;
СтрокаСуммыДолга.Сумма = ОстатокДебет;
СтрокаСуммыДолга.СуммаВзаиморасчетов = ОстатокДебет;
СтрокаСуммыДолга.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;
СтрокаСуммыДолга.СчетУчетаРасчетов = ПланыСчетов.Хозрасчетный.НайтиПоКоду(СимволСчета);
Иначе
Документ.КонтрагентДебитор = Контрагент;
Документ.СуммыДолга.Очистить();
СтрокаСуммыДолга = Документ.СуммыДолга.Добавить();
СтрокаСуммыДолга.ВидЗадолженности = Перечисления.ВидыЗадолженности.Кредиторская;
СтрокаСуммыДолга.ДоговорКонтрагента = ПолучитьДоговор(Документ.КонтрагентДебитор);
Если Лев(СимволСчета,3) = "361" Тогда
СтрокаСуммыДолга.ТипКонтрагента = Перечисления.СтатусыКонтрагентов.Покупатель;
Иначе
СтрокаСуммыДолга.ТипКонтрагента = Перечисления.СтатусыКонтрагентов.Поставщик;
КонецЕсли;
СтрокаСуммыДолга.КратностьВзаиморасчетов = 1.00;
СтрокаСуммыДолга.КурсВзаиморасчетов = 1.00;
СтрокаСуммыДолга.Сумма = ОстатокКредит;
СтрокаСуммыДолга.СуммаВзаиморасчетов = ОстатокКредит;
СтрокаСуммыДолга.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;
СтрокаСуммыДолга.СчетУчетаРасчетов = ПланыСчетов.Хозрасчетный.НайтиПоКоду(СимволСчета);
КонецЕсли;
Документ.ВалютаДокумента = Валюта;
Документ.СчетДт = ПланыСчетов.Хозрасчетный.Вспомогательный;
Документ.СчетКт = ПланыСчетов.Хозрасчетный.Вспомогательный;
Документ.Записать(РежимЗаписиДокумента.Проведение);
ФайлОстатков.Следующая();
КонецЦикла;
ФайлОстатков.ЗакрытьФайл();
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8564
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.