helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Выбрать документы за период, установить значение в реквизит табличной части и провести документ

Код 1C v 8.х
 // Необходимо выбрать документы за период по ответственному
// В каждом документе, где в первой строке табличного поля не заполнен реквизит Статья
// заполнить, и провести документ
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| РасходныйКассовыйОрдер.Ссылка
|ИЗ
| Документ.РасходныйКассовыйОрдер КАК РасходныйКассовыйОрдер
|ГДЕ
| РасходныйКассовыйОрдер.Дата МЕЖДУ &ДатаН И &ДатаК
| И РасходныйКассовыйОрдер.Ответственный = &Ответственный";
Запрос.УстановитьПараметр("ДатаН", ЭлементыФормы.НачПериода.Значение);
Запрос.УстановитьПараметр("ДатаК", ЭлементыФормы.КонПериода.Значение);
Запрос.УстановитьПараметр("Ответственный", Ответственный);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
// получим документ для обработки
Док = Выборка.Ссылка.ПолучитьОбъект();
//Проверим заполнение реквизита СтатьяДвиженияДенежныхСредств в первой строке табл. поля
Если ПустаяСтрока(Док.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств) тогда
Док.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств=СтатьяЗатрат;
Док.Записать(РежимЗаписиДокумента.Проведение);
Сообщить(Док);
КонецЕсли;
КонецЦикла;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 16944
 0 
Распечатать
Возможно, вас также заинтересует
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 1
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное...
Ввести дату, ввод даты 1
ДатаНапоминания = РабочаяДата; Подсказка = "Введите дату и время"; ЧастьДаты = ЧастиДаты.ДатаВремя; Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда // обработка даты напоминания КонецЕсли Если...
Ввести значение, ввод значения 0
//Пример универсального ввода значения Перем ВыбЗнач; Массив = Новый Массив; Массив.Добавить(Тип("Число")); Массив.Добавить(Тип("Строка")); Массив.Добавить(Тип("Дата")); КЧ = Новый КвалификаторыЧисла(12,2); КС = Новый...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.