helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функции преобразуют табличный документ (ТД) в строку и обратно

Код 1C v 8.х
 Функция ТабличныйДокументВСтроку(ТД) Экспорт
Попытка
ИмяФайла=ПолучитьИмяВременногоФайла("MXL");
ТД.Записать(ИмяФайла);
ДД=Новый ДвоичныеДанные(ИмяФайла);
Стр=Base64Строка(ДД);
ДД=Неопределено;
УдалитьФайлы(ИмяФайла);
Возврат Стр;
Исключение
Возврат Неопределено;
КонецПопытки;
КонецФункции

Функция ТабличныйДокументИЗСтроки(ТД, Стр) Экспорт
Если СокрЛП(Стр)="" Тогда
Возврат ложь;
КонецЕсли;
Попытка
ДД=Base64Значение(Стр);
ИмяФайла=ПолучитьИмяВременногоФайла("MXL");
ДД.Записать(ИмяФайла);
ДД=Неопределено;
ТД.Прочитать(ИмяФайла);
УдалитьФайлы(ИмяФайла);
Возврат истина;
Исключение
Возврат ложь;
КонецПопытки;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6589
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
В регламентированной отчетности не печается штрих-код 1С ( EanGnivc ) 0
Установка шрифта EanGnivc В формах регламентированной отчетности, например, налоговые декларации, которые введены для предоставления отчетности, на всех листах в левом верхнем углу содержат свой уникальный штрих-код. В...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.