helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как при выводе данных в Табличный Документ изменить Текст и Цвет Текста конкретной ячейки?

Код 1C v 8.х
  //Пример изменения цвета текста при выводе данных в табличный документ
Таб.ВывестиСекцию("Контрагент");
// Изменим Текст ячейки, имя которой заранее задали как "ТекстОСостоянии"
Таб.Область("ТекстОСостоянии").Текст = "Хорошо )";
// В зависимости от условия изменим Цвет Текста
Если Раз<0 Тогда
Таб.Область(Таб.ВысотаТаблицы(),9,Таб.ВысотаТаблицы(),9).ЦветТекста(255,0,0);
ИначеЕсли Раз>0 Тогда
Таб.Область(Таб.ВысотаТаблицы(),9,Таб.ВысотаТаблицы(),9).ЦветТекста(0,0,255);
КонецЕсли;


Код 1C v 7.x
 Таб = СоздатьОбъект("Таблица");
Таб.Открыть("tabldoc.mxl");
ВыбОбласть = Таб.Область("R8C4");
ВыбОбласть.Шрифт("Arial");
ВыбОбласть.РазмерШрифта(10);
ВыбОбласть.Подчеркнутый(1);
ВыбОбласть.ГоризонтальноеПоложение(3);
ВыбОбласть.Контроль(4);
ВыбОбласть.ЦветФона(34, 126, 211); // Фон
ВыбОбласть.ЦветРамки(34, 126, 211); // Рамка
ВыбОбласть. ЦветТекста>(34, 126, 211); // Текст
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 18755
 0 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
База для Разработки или Рабочая? Как быстро определить? 1
Когда-то я работал консультантом SAP . В SAPe есть настройка изменения цвета главного окна программы и у нас было негласное правило: Рабочая программа - Красный фон , Тестовая - Зеленый , Разработка - Синий . Работая в 1С,...
Ввести строку, ввод текста 0
Текст = ""; Подсказка = "Введите текст напоминания"; Если ВвестиСтроку(Текст,Подсказка, 0, истина) Тогда // запомнить текст напоминания КонецЕсли; НК = ""; Если ВвестиСтроку(НК, "Введите код продукции", 40, 1, 9) = 1 Тогда Koд...
Выбор ~ Как открыть пользователю стандартный диалог выбора Цвета или Шрифта? 0
Диалог = Новый ДиалогВыбораЦвета; Если Диалог.Выбрать() Тогда ВыбранныйЦвет = Диалог.Цвет; КонецЕсли; Диалог = Новый ДиалогВыбораШрифта; Если Диалог.Выбрать() Тогда ВыбранныйШрифт = Диалог.Шрифт; КонецЕсли;
Выбор оптимального алгоритма для разбора строки в массив 0
Столкнулся с проблемой: ПолучитьСтрокуПоНомеру() медленно отрабатывает на входных данных 100 000 строк. Как сделать бытсрее? // Пример Defender aka LINN ВремяНачала = ТекущаяДата(); Сообщить(" Обработка начата: " + ВремяНачала); ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.