helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Форма ~ Как определить что форма стала активной?

Используйте ВводДоступен

ВводДоступен (IsInputAvailable)
Синтаксис:
ВводДоступен()

Возвращаемое значение:
Тип: Булево. Истина - ввод данных в форму возможен (форма активна); Ложь - форма не активна.
Описание:
Определяет, возможен ли ввод данных в форму. Может быть использован для того, чтобы определить, активизирована ли текущая форма.
Недоступен на сервере 1С:Предприятие. Не используется в модуле внешнего соединения.
Код 1C v 8.х
 
//При открытии формы
ПодключитьОбработчикОжидания("Проверка",1);

//Принудительная Активация формы, если необходима
Форма.Активизировать();

// процедура проверка, для обработчика
Процедура Проверка()
Если ВводДоступен() Тогда
Сообщить("Введите текст");
КонецЕсли;
КонецПроцедуры;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 12992
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.