helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Метод сортировки числового ряда шейкером

Вариант сортировки числового ряда (от малого к великому) методом шейкера. Считается более оптимизированным и быстрым алгоритмом сортировки по сравнению с сортировкой пузырьковым методом. Однако, есть тоже ряд отрицательных сторон (ну куда же без них). Подробно обо всём расскажет google, ну а ниже приведён код функции. Область применения так же достаточно широка.

Код 1C v 8.х
 
Функция СортировкаШейкеромРядаЧисел(МассивЭлементов) Экспорт
// Определяем границы массива
НижняяГраница = 0;
ВерхняяГраница = МассивЭлементов.Количество()-1;
// Определяем счётчики циклов, они же - границы неотсортированной части массива
счётчик1 = МассивЭлементов.Количество()-1;
счётчик2 = 0;

// Поехали сортировать массив
Пока НижняяГраница < ВерхняяГраница Цикл
// Проход снизу вверх
Пока счётчик1 >= 0 Цикл
счётчик1 = счётчик1-1;
Если счётчик1 = 0 Тогда
Прервать;
КонецЕсли;
Если МассивЭлементов[счётчик1-1] > МассивЭлементов[счётчик1] Тогда
МладшийЭлемент = МассивЭлементов[счётчик1];
СтаршийЭлемент = МассивЭлементов[счётчик1-1];

МассивЭлементов[счётчик1-1] = МладшийЭлемент;
МассивЭлементов[счётчик1] = СтаршийЭлемент;

счётчик2 = счётчик1;
КонецЕсли;
КонецЦикла;

НижняяГраница = счётчик2+1;

// Проход сверху вниз
счётчик1 = 0;
Пока счётчик1 <= ВерхняяГраница Цикл
счётчик1 = счётчик1+1;
Если счётчик1 = МассивЭлементов.Количество() Тогда
Прервать;
КонецЕсли;
Если МассивЭлементов[счётчик1-1] > МассивЭлементов[счётчик1] Тогда
МладшийЭлемент = МассивЭлементов[счётчик1];
СтаршийЭлемент = МассивЭлементов[счётчик1-1];

МассивЭлементов[счётчик1-1] = МладшийЭлемент;
МассивЭлементов[счётчик1] = СтаршийЭлемент;
счётчик2 = счётчик1;
КонецЕсли;
КонецЦикла;

ВерхняяГраница = счётчик2-1;
КонецЦикла;

Возврат МассивЭлементов;
КонецФункции

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6871
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.