helpf.pro
Регистрация
 +2 
Распечатать

1С 8.x : Как включить использование итогов регистров накопления и бухгалтерии?

Код 1C v 8.х
 Процедура КнопкаВыполнитьНажатие(Кнопка)
Для Каждого Рег Из РегистрыНакопления Цикл
Если Рег.ПолучитьИспользованиеИтогов()=Ложь Тогда
Рег.УстановитьИспользованиеИтогов(Истина);
Состояние("Идет пересчет итогов регистра накопления " + Рег);
Рег.ПересчитатьИтоги();
Сообщить("Для регистра накопления " + Рег + " включено использование итогов");
КонецЕсли;
КонецЦикла;
Для Каждого Рег Из РегистрыБухгалтерии Цикл
Если Рег.ПолучитьИспользованиеИтогов()=Ложь Тогда
Рег.УстановитьИспользованиеИтогов(Истина);
Состояние("Идет пересчет итогов регистра бухгалтерии " + Рег);
Рег.ПересчитатьИтоги();
Сообщить("Для регистра бухгалтерии " + Рег + " включено использование итогов");
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 9646
 +2 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Восстановление партионного учета в УТ 0
Проблема следующая: при выполнении стандартной обработки " проведение по партиям" , непонятно почему, но граница актуальности партионного учета не сдвигается, хотя при перепроведении документов никаких ошибок не...
Временные таблицы 0
Не помню уже с какого релиза в запросах стало можно использовать временные таблицы. Для этого используется объект «Менеджер временных таблиц». Фактически менеджер временных таблиц описывает пространство имен...
Временные таблицы в отчетах СКД 0
Нужно в отчете СКД Связать Данные из Регистра Накопления ВзаиморасчетыСРаботниками и Табличной Части Документа ЗарплатаКВыплате по Ссылке на Документ и ФизЛицу! И вывести полученные данные за указанный Период(с...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.