helpf.pro
Регистрация
 +1 
Распечатать

1С 8.x : Загрузка данных из таблицы значений в регистр сведений

В документе есть табличная часть вида
№ Инвентарная группа Январь Февраль Март Апрель ... и т.д.
1 Бумага 150 175 130 140 ...
1 Кантовары 50 15 30 27 ...
1 Хозтовары 10 29 37 60 ...

Нужно выгрузить табличную часть документа в Таблицу значений и загрузить в регистр сведений

Период Дата Подразделение Инвентарная группа Количество
01.01.2010 01.01.2010 Хоз. Отдел Бумага 150
01.01.2010 02.01.2010 Хоз. Отдел Бумага 175
01.01.2010 03.01.2010 Хоз. Отдел Бумага 130
...........................
01.01.2010 01.01.2010 Хоз. Отдел Кантовары 50
01.01.2010 02.01.2010 Хоз. Отдел Кантовары 15
01.01.2010 03.01.2010 Хоз. Отдел Кантовары 30
.....
и т.д

вот примерный код:
Код 1C v 8.х
  ТЗ = Новый ТаблицаЗначений;
ТЗ = СписокИнвентарныхГрупп.Выгрузить();
СчетчикКолонок = 2;
СчетчикСтрок = 0;
Пока СчетчикСтрок < СписокИнвентарныхГрупп.Количество()Цикл
Пока СчетчикКолонок<=13 Цикл
НаборДанных = РегистрыСведений.ЛимитыИнвентаря.СоздатьНаборЗаписей();
НаборДанных.Отбор.ИнвентарнаяГруппа.Установить(ТЗ[СчетчикСтрок][1]);
НаборДанных.Отбор.Подразделение.Установить(ПОдразделение);
НаборДанных.Отбор.Дата.Установить(ДобавитьМесяц(НачалоГода(Период),СчетчикКолонок-2));
НаборДанных.Прочитать();
Если НаборДанных.Количество() = 0 Тогда
Запись = НаборДанных.Добавить();
Иначе
Запись = НаборДанных[0];
КонецЕсли;
Запись.Подразделение = Подразделение;
Запись.ИнвентарнаяГруппа = ТЗ[СчетчикСтрок][1];
Запись.Дата = ДобавитьМесяц(НачалоГода(Период),СчетчикКолонок-2);
Запись.Количество = ТЗ[СчетчикСтрок][СчетчикКолонок+1];
Запись.Период = Период;
НаборДанных.Записать();
СчетчикКолонок = СчетчикКолонок+1;
КонецЦикла;
СчетчикСтрок = СчетчикСтрок+1;
СчетчикКолонок = 2;
КонецЦикла;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 14703
 +1 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Будут ли работать два клиентских ключа защиты 1С:Предприятия 8 на одном компьютере? 0
Рекомендуем ознакомиться с документацией по 1С:Предприятию 8. " Руководства по установке и запуску" , глава 6, второй абзац: " ... К USB-портам одного компьютера не имеет смысла присоединять несколько аппаратных ключей HASP4...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.