helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Перемещение между документами в списке

Код 1C v 8.х
 //black_doctor, надеюсь комунить пригодиться механизм )))
//
//В примере описан механизм перехода между документами одного типа
//функции помещаються в общие , ну и от туда работают, для любого документа )
//в качестве входящих параметров задаем ссылку на документ и ссылку на текущую форму )

Процедура СледующийНажатие(док,ТекФорма) Экспорт
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ Первые 1
| ОперацииЦБ.Ссылка КАК Ссылка
|ИЗ
| ";
Запрос.Текст = Запрос.Текст+"Документ."+Док.ссылка.Метаданные().Имя+"
КАК ОперацииЦБ
|ГДЕ
| ОперацииЦБ.МоментВремени > &МоментВремени
|
|УПОРЯДОЧИТЬ ПО
| ОперацииЦБ.МоментВремени";
Запрос.УстановитьПараметр("МоментВремени",док.МоментВремени());
Результат = Запрос.Выполнить().Выгрузить();
Если Результат.Количество()>0 тогда
Формочка = Результат[0].Ссылка.ПолучитьОбъект().ПолучитьФорму();
Формочка.ПоложениеОкна = ТекФорма.ПоложениеОкна;
ТекФорма.Закрыть();
Формочка.Открыть();
Иначе Сообщить("Этот документ первый в списке документов",СтатусСообщения.Внимание);
КонецЕсли;
КонецПроцедуры

Процедура ПредыдущийНажатие(док,ТекФорма) Экспорт
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ Первые 1
| ОперацииЦБ.Ссылка КАК Ссылка
|ИЗ
| ";
Запрос.Текст = Запрос.Текст+"Документ."+Док.ссылка.Метаданные().Имя+"
КАК ОперацииЦБ
|ГДЕ
| ОперацииЦБ.МоментВремени < &МоментВремени
|
|УПОРЯДОЧИТЬ ПО
| ОперацииЦБ.МоментВремени УБЫВ";
Запрос.УстановитьПараметр("МоментВремени",док.МоментВремени());
Результат = Запрос.Выполнить().Выгрузить();
Если Результат.Количество()>0 тогда
Формочка = Результат[0].Ссылка.ПолучитьОбъект().ПолучитьФорму();
Формочка.ПоложениеОкна = ТекФорма.ПоложениеОкна;
ТекФорма.Закрыть();
Формочка.Открыть();
Иначе Сообщить("Этот документ первый в списке документов",СтатусСообщения.Внимание);
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 6520
 0 
Распечатать
Возможно, вас также заинтересует
В регламентированной отчетности не печается штрих-код 1С ( EanGnivc ) 0
Установка шрифта EanGnivc В формах регламентированной отчетности, например, налоговые декларации, которые введены для предоставления отчетности, на всех листах в левом верхнем углу содержат свой уникальный штрих-код. В...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Выгрузка табличного документа в Google таблицу 0
Надумал когда-то задачу себе: выгрузить содержимое табличного документа в Google Document . Одним из вариантов использования данного функционала может быть выгрузка состояния заказов пользователей из базы в 1с в google spreadsheet....
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.