helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Универсальное использование HTML Редактора

Гуляя по просторам интернета, случайно наткнулся на обработку HTML Редактор (Андрей Михайлов aka MAV):

title

Далее, пришла в голову интересная идея, сделать красивыми комментарии в документах ( у нас они очень большие и многострочные, в отдельной закладке), с поддержкой копирования информации из WORD и EXCEL, с сохранением всех цветов и стилей. Подредактировав данную обработку, стали доступны следующие функции:

1. Добавление текста

2. Добавление, просмотр и печать

3. Просмотр и печать

Теперь, более подробно:

Вот так выгляди поле комментариев в нашей базе:
title

1. Нажав на кнопку "Добавить комментарий" срабатывает Процедура ДобавитьКоммент(Элемент)
Код 1C v 8.х
 
Процедура ДобавитьКоммент(Элемент)
форм=обработки.HTML.ПолучитьФорму("Форма");
текст = форм.ОткрытьМодально();
если не Пустаястрока(текст) тогда
комментарий="Добавил: "+глтекущийпользователь+" , Добавлено: "+текущаядата()+текст+комментарий;
ЭлементыФормы.ПолеHTMLДокумента.УстановитьТекст(комментарий);
конецесли;
КонецПроцедуры

2. Процедура вызова "Добавление, просмотр и печать"
Код 1C v 8.х
 
Процедура ВставитьПланГрафик(Кнопка)
форм=обработки.HTML.ПолучитьФорму("ФормаПросмотра");
форм.текст=ПланГрафик;
текст=форм.ОткрытьМодально();
ПланГрафик=текст+ПланГрафик;
КонецПроцедуры

Откроется форма, вида:
title

Нажав на "Добавить запись" и вставив Таблицу из Excel:
title

Нажимаем Добавить и получаем:
title

3. Просмотр и печать
Код 1C v 8.х
 
Процедура ИсторияИзмененийПросмотр(Кнопка)
форм=обработки.HTML.ПолучитьФорму("Просмотр");
форм.текст=ИсторияИзменений;
форм.ОткрытьМодально();
КонецПроцедуры

Откроется форма просмотра реквизита ИсторияИзменений.

Обработка HTML редактор:
Для 8.0
Для 8.1
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 11176
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Временные таблицы, как проверить в отладчике? 0
// Функция для просмотра Временных Таблиц в отладчике Функция ЛукВТ(Запрос, ИмяВнутреннейТаблицы) Экспорт Перем ЗапросТМП, Р; //Получаем таблицу из менеджера временных таблиц запроса ЗапросТМП=Новый Запрос(" ВЫБРАТЬ...
Выбрать Остатки и Обороты по указанным счетам, отбор по субконто и выгрузка результата в EXCEL 0
Запрос=Новый Запрос; Запрос.Текст=" |ВЫБРАТЬ | ХозрасчетныйОстаткиИОбороты.Счет, | ХозрасчетныйОстаткиИОбороты.Субконто1, | ХозрасчетныйОстаткиИОбороты.Субконто2, | ХозрасчетныйОстаткиИОбороты.Субконто3, ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.