helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Выгрузка форматированного документа 1С на свой сайт

Пользователи в 1с ведут описание объектов, которые редактируются в объекте ФорматированныйДокумент. Необходимо обеспечить выгрузку форматированного документа на фтп.

Для решения этой задачи воспользуемся методом форматированного документа ПолучитьHTML(). Этот метод вернет нам сам текст html документа и структуру картинок. После выполнения данного метода нам следует выгрузить картинки на наш сайт. Во время выгрузки картинок определяем тип картинки и на основании этого определяем расширение файла. Поэтому нам надо и подкорректировать сам текст html, так как источник картинки в нем по умолчанию прописывается в виде «image001″ (без расширения). Эта корректировка не критична для нас, страница будет отображаться нормально, но отдельно по ссылке открыть рисунок будет проблематично.
Код функции:
Код 1C v 8.2 УП
 &НаСервере
Функция ВыгрузитьОбъект(ТекОбъект) Экспорт
РезультатВыгрузки = "";

//проверим есть ли описание объекта в базе
ФорматированныйДокумент = ТекОбъект.Описание.Получить();
Если ФорматированныйДокумент = Неопределено Тогда
РезультатВыгрузки = " У данного объекта не определено описание. Выгрузка объекта остановлена";
Возврат РезультатВыгрузки;
КонецЕсли;

//Определяем настройки подключения к фтп
Сервер = ХранилищеНастроек.ФТПСервер;
Порт = ХранилищеНастроек.ФТПпорт;
ИмяПользователяФТП = ХранилищеНастроек.ФТПИмяПользователя;
ПарольПользователяФТП = ХранилищеНастроек.ФТППароль;
ТекущийКаталогFTP = ХранилищеНастроек.ФТПТекущийКаталог;

ФТП = Новый FTPСоединение(Сервер,,ИмяПользователяФТП,ПарольПользователяФТП);

Попытка
ФТП.УстановитьТекущийКаталог(ТекущийКаталогFTP);
Исключение
РезультатВыгрузки = "Невозможно подключиться к фтп";
Возврат РезультатВыгрузки;
КонецПопытки;

ИмяКаталогаОбъекта = Формат(ТекОбъект.Ссылка.Код, "ЧЦ=5; ЧВН=; ЧГ=");

//Каталог для элемента
Попытка
ФТП.УстановитьТекущийКаталог(ТекущийКаталогFTP + "/" + ИмяКаталогаОбъекта);
Исключение
ФТП.СоздатьКаталог(ИмяКаталогаОбъекта);
ФТП.УстановитьТекущийКаталог(ТекущийКаталогFTP + "/" + ИмяКаталогаОбъекта);
РезультатВыгрузки = РезультатВыгрузки + Символы.ПС + " Создан каталог " + ТекущийКаталогFTP + "/" + ИмяКаталогаОбъекта;
КонецПопытки;

//Чистка имеющихся элементов в каталоге элемента
ФТП.Удалить(ТекущийКаталогFTP + "/" + ИмяКаталогаОбъекта,"*.*");

ТекстХТМЛ = "";
СтруктураКартинок = Новый Структура;
ФорматированныйДокумент.ПолучитьHTML(ТекстХТМЛ, СтруктураКартинок);

//Выгрузка картинок и корректировка ХТМЛ
Для Каждого ТекКартинка Из СтруктураКартинок Цикл
ИмяТемпФайла = ПолучитьИмяВременногоФайла();
ТекКартинка.Значение.Записать(ИмяТемпФайла);
ФорматТекущейКартинки = Строка(ТекКартинка.Значение.Формат());
Если Не ФорматТекущейКартинки = ФорматКартинки.НеизвестныйФормат Тогда
ФорматТекущейКартинкиСтрока = Строка(ФорматТекущейКартинки);
ТекстХТМЛ = СтрЗаменить(ТекстХТМЛ,ТекКартинка.Ключ,ТекКартинка.Ключ+ "." + ФорматТекущейКартинкиСтрока);
ФТП.Записать(ИмяТемпФайла, ТекКартинка.Ключ+ "." + ФорматТекущейКартинкиСтрока);
РезультатВыгрузки = РезультатВыгрузки + Символы.ПС + " Записан файл " + ТекКартинка.Ключ+ "." + ФорматТекущейКартинкиСтрока;
Иначе
ФТП.Записать(ИмяТемпФайла, ТекКартинка.Ключ);
РезультатВыгрузки = РезультатВыгрузки + Символы.ПС + " Записан файл " + ТекКартинка.Ключ;
КонецЕсли;
КонецЦикла;

//ВыгрузкаХТМЛ
ИмяТемпФайла = ПолучитьИмяВременногоФайла("html");
ФайлHТМЛ = Новый ТекстовыйДокумент;
ФайлHТМЛ.ДобавитьСтроку(ТекстХТМЛ);
ФайлHТМЛ.Записать(ИмяТемпФайла);

//Собственно запись хтмл
ФТП.Записать(ИмяТемпФайла, ИмяКаталогаОбъекта + ".html");
РезультатВыгрузки = РезультатВыгрузки + Символы.ПС + " Записан файл " + ИмяКаталогаОбъекта + ".html";

Возврат РезультатВыгрузки;
КонецФункции

Андрей Данилюк
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 6284
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.