helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Удаление из строки всех нечисловых символов

Иногда необходимо избавиться от нечисловых символов в строке. Например если сканер штрихкода или ридер магнитных карт добавляют в считываемую строку свои служебные символы.

Вот нехитрая функция для решения этой задачи

Код 1C v 7.x
 
Функция УбратьНечисловые(Стр)
ОбрСтр = СокрЛП(Стр);
Результат = ОбрСтр;
Для н=1 по СтрДлина(ОбрСтр) Цикл
ТекСимвол = Сред(ОбрСтр,н,1);
Если Найти("0123456789",ТекСимвол) = 0 Тогда
Результат = СтрЗаменить(Результат,ТекСимвол,"");
КонецЕсли;
КонецЦикла;
Возврат Результат;
КонецФункции
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 8963
 0 
Распечатать
Возможно, вас также заинтересует
Загрузка данных из текстовых файлов, выбирая SQL запросом данные из этих файлов 0
Часто бывает потребность загружать данные из текстовых форматов, причем информация для загрузки бьется на 2 и более файлов. Хорошо бы посредством SQL запроса выбирать данные из этих файлов и производить загрузку! Это...
Запрос по вхождению искомой строки в наименования элементов справочника 0
В данной статье я расскажу вам как быстро найти в справочнике элементы у которых в наименовании присутствует вхождение искомой нами строки: Текст запроса будет выглядеть так: Запрос = Новый Запрос; Запрос.Текст = ...
Использование ASCII кодов в 1С 2
Хотите писать в 1С не только стандартными буквами, знаками изображенными на клавиатуре и вставлять опять же стандартные смайлики, а тем не менее существует возможность ставить дополнительные символы, так же можно...
Как в запросе одно строковое поле разделить на два ( ПОДСТРОКА )? 0
Задача состояла в том, что нужно было из реквизита документа Сответствие выделить две строки и сделать сортировку по ним. Соответствие счета, такого вида: 779000/004599. Как разбить это значение на два? У функции ПОДСТРОКА...
Как мы писали парсер сайта с ценами для 1С 1
Недавно, мой постоянный клиент решил проводить маркетинговые исследования по изменению цен на товары у конкурентов... и эти данные захотел использовать в 1С в связке с его прайс-листом + куча отчетов с графиками и...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.