helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : ФорматированнаяСтрока

тип данных ФорматированнаяСтрока - доступен с версии 8.3!
Форматированные строки можно использовать в следующих случаях:
В качестве данных для элементов формы поле надписи
В качестве заголовка поля формы типа декорация;
В качестве параметра ТекстПредупреждения метода Предупреждение();
В качестве параметра ТекстВопроса метода Вопрос().

Пример1:
Код 1C v 8.2 УП
 Реквизит1 = Новый ФорматированнаяСтрока("Товар ", Новый ФорматированнаяСтрока(" Телевизор", , WebЦвета.Красный), " отсутствует на складе");
Предупреждение(Реквизит1);

В результате предупреждении выглядит следующим образом:
title

Пример 2:
Код 1C v 8.2 УП
 &НаКлиенте
Процедура ПроверкаФорматированнойСтроки(Команда)
Строка1 = Новый ФорматированнаяСтрока("Этот тест будет жирный и наклонный", Новый Шрифт(,,Истина, Истина));
Строка2 = Новый ФорматированнаяСтрока("Оранжевый текст",,Новый Цвет(255,140,0));
ОбщаяСтрока = Новый ФорматированнаяСтрока(Строка1, "-", Строка2);
Режим = РежимДиалогаВопрос.ДаНет;
Ответ = Вопрос(ОбщаяСтрока, Режим, 40);
Если Ответ = КодВозвратаДиалога.Нет Тогда
Возврат;
КонецЕсли;
КонецПроцедуры
В результате вы увидете:
Этот тест будет жирный и наклонный-Оранжевый текст
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 7730
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 3
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C медленно работает по сети с базой на SQL Server 9
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1С Предприятие что это? 7
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.