helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как программно выполнить задачу БП?

Код 1C v 8.2 УП
 &НаСервере
Процедура ЗафиксироватьВыполнениеНаСервере()

ЗадачаОбъект = Задача.Ссылка.ПолучитьОбъект();

ЗадачаОбъект.ВыполнитьЗадачу();

КонецПроцедуры


Код 1C v 8.х
 ТекстВопроса = "Задача будет завершена. Продолжить?";
ОтветНаВопрос = Вопрос(ТекстВопроса,РежимДиалогаВопрос.ОКОтмена,,КодВозвратаДиалога.ОК);
Если ОтветНаВопрос = КодВозвратаДиалога.ОК Тогда
ВыполнитьЗадачуИнтерактивно();
ЗаписатьВФорме();

// условие для БП Поручение
Если ТипЗнч(БизнесПроцесс) = Тип("БизнесПроцессСсылка.CRM_Поручение")
И (ТочкаМаршрута.Имя = "Контроль")Тогда
БизнесПроцессЗадачи = ЗадачаОбъект.БизнесПроцесс.ПолучитьОбъект();
БизнесПроцессЗадачи.КачествоВыполнения = ЭлементыФормы.Оценка.Значение;
БизнесПроцессЗадачи.Записать();
КонецЕсли;
Закрыть();
КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 7121
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Ввод по строке - поиск по первым символам или в любом месте наименования 0
При разработке конфигурации, для упрощении ввода документов потребовалось настроить ввод номенклатуры по совпадению любой части наименования! В 1С 8.3 по умолчанию настройки справочника номенклатуры такие: При...
Использование Web-сервисов для синхронизации баз данных в режиме online 1с 8.х 7
Часто при ведении учета в различных конфигурациях 1с возникает необходимость выполнения обмена данных. Для решения этой задачи принято использовать Универсальный обмен данными XML или другие внешние обработки, общим...
Как в запросе одно строковое поле разделить на два ( ПОДСТРОКА )? 0
Задача состояла в том, что нужно было из реквизита документа Сответствие выделить две строки и сделать сортировку по ним. Соответствие счета, такого вида: 779000/004599. Как разбить это значение на два? У функции ПОДСТРОКА...
Как в запросе получить срез последних на Каждую Дату 3
Данная задача может быть решена как с использованием вложенных запросов, так и с помощью. временных таблиц. Попробуем решить задачу, используя временные таблицы. Сначала приведем весь текст запроса, а потом кратко...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.