helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Внешняя печатная форма, дополнительные параметры для печати

Внешняя обработка (Печатная форма), содержащая: Необязательный реквизит «ДополнительныеПараметры» произвольного типа, которому будут передаваться дополнительные параметры примитивного типа в виде структуры.
title
Аналогично можно передать параметр во внешнюю печатную форму через реквизит «ДополнительныеПараметры».
В модуле обработки для использования этих параметров используем следующий код вида:
Код 1C v 8.х
 Если ТипЗнч(ДополнительныеПараметры) = Тип("Структура") Тогда
Если ДополнительныеПараметры.Свойство("КодФилиала") Тогда
КодФилиала = ДополнительныеПараметры.КодФилиала;
Иначе
КодФилиала="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("КодОрганизации") Тогда
КодОрганизации = ДополнительныеПараметры.КодОрганизации;
Иначе
КодОрганизации="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("ОтделениеБанка") Тогда
ОтделениеБанка = ДополнительныеПараметры.ОтделениеБанка;
Иначе
ОтделениеБанка="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("НомерДоговора") Тогда
НомерДоговора = ДополнительныеПараметры.НомерДоговора;
Иначе
НомерДоговора="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("ДатаДоговора") Тогда
ДатаДоговора = ДополнительныеПараметры.ДатаДоговора;
Иначе
ДатаДоговора="";
КонецЕсли;
КонецЕсли;


Настроим передачу параметров внешней печатной форме
Для этого создаем новый элемент справочника «Внешние обработки» и заполняем его, как показано на рисунке ниже
В табличной части открываем Параметры обработки и вводим значения параметров
title
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 14639
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.