helpf.pro
Регистрация
 +18 
Распечатать

1С 8.2 УП : Произвольный макет в СКД

Делал недавно отчет с неопределенным количеством колонок. Возиться с кодом было неохота, решил сделать на СКД. С этим проблема не возникла, необходимо было натянуть результат на произвольный макет (свой заголовок + период). Покажу на примере по шагам, с чем столкнулся и как решил.

Первоначальную настройку схемы СКД описывать не буду, начнем с того, что мне надо было сделать произвольный заголовок. В нашем случае, формируем представление периода отчета.
Добавляем новый параметр "ПредставлениеПериода", тип Строка.
title

Теперь добавляем новое поле группировки, поля группировок не выбираем (Детальные записи), удаляем поле "Авто", переносим наш параметр.
title

Переходим на вкладку "Макет", рисуем шапку. Добавляем Заголовок группировки. Мы можем использовать Имя группировки, если заранее задали его в схеме компоновки, или выбрать из доступных полей. После этого определяем область в табличном документе. Далее, прописываем наш параметр на макете, потом необходимо будет установить в свойствах этой ячейки свойство "Заполнение" - "Параметр". И в окне параметров макета связать наш параметр с параметром СКД.
title

Теперь немного кода. Создаем форму отчета. Отключаем видимость у Основной Командной Панели и Компоновщика Настроек. Создаем нашу команду "Сформировать", реквизит формы "Дата", перетаскиваем все это на форму. Пишем код в модуле формы:

Код 1C v 8.2 УП
 &НаСервере
Процедура УстановитьПараметрыКомпоновки()

пОтчета = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Период");
Если НЕ пОтчета = Неопределено Тогда
пОтчета.Значение = КонецДня(Дата);
КонецЕсли;
ПредставлениеПериода = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("ПредставлениеПериода");
Если НЕ ПредставлениеПериода = Неопределено Тогда
ПредставлениеПериода.Значение = "Остатки по складам на " + Формат(Дата, "ДЛФ=Д");
КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура СформироватьНаСервере()

УстановитьПараметрыКомпоновки();

Результат.Очистить();

СхемаКомпоновкиДанных = РеквизитФормыВЗначение("Отчет").СхемаКомпоновкиДанных;
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Отчет.КомпоновщикНастроек.Настройки, ДанныеРасшифровки);

ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);

ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(Результат);
ПроцессорВывода.ОтображатьПроцентВывода = Истина;

ПроцессорВывода.Вывести(ПроцессорКомпоновки);

КонецПроцедуры

&НаКлиенте
Процедура Сформировать(Команда)

СформироватьНаСервере();

КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)

Дата = ТекущаяДата();

КонецПроцедуры


После этого, если все правильно сделали, результат отчета должен выглядеть вот так:
title

Теперь попробуем сделать полностью свой произвольный макет на СКД .
Здесь самое главное понять структуру областей макета в СКД. Разберем пример с неопределенным количеством колонок.

Заготовка для отчета выглядит так:
title

Пример результата:
title

Теперь создаем свой макет:

1. Добавляем шапку по аналогии с прошлым примером. Устанавливаем макет оформления "Без оформления". Итоги по номенклатуре выводить не будем, поэтому ставим у таблицы настройку "Расположение общих итогов по горизонтали" - "Нет".
title

2. Теперь создаем макет, прописываем параметры, настраиваем дополнительные свойства ячеек. Например, для номенклатуры можно выставить в свойстве "Размещение текста" значение "Переносить" вместо "Авто", а так же указать параметры расшифровки.
title

3. Теперь самое интересное, назначаем области. Структура областей будет выглядеть таким образом:
title

Начинаем создавать области, параметры при этом будут автоматически сопоставляться по именам. В итоге должно получиться следующее:
title

Проверяем отчет, должно получиться следующее:
title

4. Пишем код по аналогии с прошлым примером:
Код 1C v 8.2 УП
 &НаСервере
Процедура УстановитьПараметрыКомпоновки()

пОтчета = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Период");
Если НЕ пОтчета = Неопределено Тогда
пОтчета.Значение = Период;
КонецЕсли;
ПредставлениеПериода = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("ПредставлениеПериода");
Если НЕ ПредставлениеПериода = Неопределено Тогда
ПредставлениеПериода.Значение = "Заказы контрагентов за " + Формат(Период.ДатаНачала, "ДЛФ=Д") + " - " + Формат(Период.ДатаОкончания, "ДЛФ=Д");
КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура СформироватьНаСервере()

УстановитьПараметрыКомпоновки();

Результат.Очистить();

СхемаКомпоновкиДанных = РеквизитФормыВЗначение("Отчет").СхемаКомпоновкиДанных;
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Отчет.КомпоновщикНастроек.Настройки, ДанныеРасшифровки);

ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);

ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(Результат);
ПроцессорВывода.ОтображатьПроцентВывода = Истина;

ПроцессорВывода.Вывести(ПроцессорКомпоновки);

//решил добавить колонтитулы )
Результат.НижнийКолонтитул.Выводить = Истина;
Результат.НижнийКолонтитул.НачальнаяСтраница = 1;
ШрифтКолонтитула=Новый Шрифт("Arial", 6);
Результат.НижнийКолонтитул.Шрифт=ШрифтКолонтитула;
Результат.НижнийКолонтитул.ТекстСлева = "Тест СКД";

КонецПроцедуры

&НаКлиенте
Процедура Сформировать(Команда)

СформироватьНаСервере();

КонецПроцедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Период.ДатаНачала = НачалоМесяца(ТекущаяДата());
Период.ДатаОкончания = ТекущаяДата();

КонецПроцедуры


В итоге у нас получается следующее:
title

Кстати, при последующем открытии отчета, вы увидите, что компоновка перестроила макет по-своему.
title
Это вполне нормально, не стоит беспокоиться.

Источник: http://start1c.blogspot.ru
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 57879
 +18 
Распечатать
Возможно, вас также заинтересует
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Внешние источники данных 0
Почему данная возможность вызывает такой интерес? Любой человек, который программировал в 1С при этом достаточно неплохо знаком с SQL и хотя бы в общих чертах знаком с архитектурой и принципами разработки других...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.