helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как открыть форму?

Код 1C v 8.2 УП
 стрПараметры = Новый Структура("Ключ", СсылкаНаКонтрагента);
ФормаОснования = ПолучитьФорму("Справочник.Контрагенты.ФормаОбъекта", стрПараметры);
ФормаОснования.Открыть();


Код 1C v 8.2 УП
 //Открытие формы редактирования календаря поставки на шаге 1.
&НаКлиенте
Процедура ИспользуемыеКалендариВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

Календарь = Элементы.ИспользуемыеКалендари.ТекущиеДанные.Календарь;
Если Календарь <> ОсновнойКалендарьПредприятия Тогда
ПараметрыФормы = Новый Структура("Ключ", Календарь);
Форма = ПолучитьФорму("Справочник.Календари.ФормаОбъекта", ПараметрыФормы);
Форма.РежимОткрытияОкна = РежимОткрытияОкнаФормы.БлокироватьОкноВладельца;
Форма.Открыть();
КонецЕсли;

КонецПроцедуры


Код 1C v 8.2 УП
 // Функция предоставляет диалог выбора рабочего места

Функция ВыбратьРабочееМесто(ОткрыватьФормуВыбораПриПервомОбращении = Ложь, ИдентификаторКлиента = "") Экспорт

Результат = Ложь;
РабочееМесто = "";

ПараметрыФормы = Новый Структура();
ПараметрыФормы.Вставить("ОткрыватьПриПервомОбращении", ОткрыватьФормуВыбораПриПервомОбращении);
ПараметрыФормы.Вставить("ИдентификаторКлиента", ИдентификаторКлиента);
ФормаВыбораРМ = ПолучитьФорму("Справочник.ПодключаемоеОборудование.Форма.ФормаВыбораРабочегоМеста", ПараметрыФормы);
Ответ = ФормаВыбораРМ.ОткрытьМодально();

Если Ответ = КодВозвратаДиалога.ОК Тогда
РМ = ФормаВыбораРМ.Параметры.РабочееМесто;

МенеджерОборудованияСервер.УстановитьРабочееМестоКлиента(РМ);

Оповестить("ИзмененоРабочееМестоТекущегоСеанса", РабочееМесто);

Результат = Истина;
КонецЕсли;

Возврат Результат;

КонецФункции
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 5071
 0 
Распечатать
Возможно, вас также заинтересует
COM-соединение не обнаружило свободной лицензии / ключ защиты 0
Иногда при подключении к 1С возникает ошибка: COM-соединение не обнаружило свободной лицензии! COM-соединение не обнаружило ключ защиты программы! https://helpf.pro/uploads/img/_1-UsuyAg6E2P.jpg В таких случаях, иногда, может помочь...
rphost занимает память и грузит процессор 12
У многих возникают проблемы с rphost.exe, разного вида: rphost занимает всю память rphost грузит процессор rphost жрет память причем 1С даже на запущена, а в диспетчере следующее: ежеминутно расчет на 2-3 мегабайта. Как быть и...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
Авто добавление обработки в справочник Внешних обработок 0
Чтобы не изменять типовую конфигурацию приходится использовать типовой механизм внешних печатных форм и обработок. Данный код проверяет - добавлена ли открываемая обработка в конфигурацию, если нет - задает вопрос и...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.