helpf.pro
Регистрация
 +7 
Распечатать

1С 8.2 УП : Использование Web-сервисов для синхронизации баз данных в режиме online 1с 8.х

Часто при ведении учета в различных конфигурациях 1с возникает необходимость выполнения обмена данных. Для решения этой задачи принято использовать Универсальный обмен данными XML или другие внешние обработки, общим у которых является использование текстовых файлов посредников.

Я предлагаю использовать Web-сервисы 1с.
В чем необходимость обмена: Обмен данными между базами требуется для исключения дублирующих вводов одних и тех же данных в различных учетных системах.
В чем необходимость обмена в режиме online: Обмен в онлайн режиме требуется когда функции учета комплекса учетных систем выполняются в разных учетных системах.
1. Например компания использует: CRM систему учета, для ведения учета взаимоотношений с клиентами; БП 2.0 для ведения взаиморасчетов с клиентами в разрезе счетов; Счета выставляемые клиентам создаются в торговой базе, а оформление заказов поставщикам исходя из потребности клиентов в базе ориентированной на работу с пайсами поставщиков. При таком разделенном построении учета, для выставления счета в одной из баз к примеру требуется завести карточку клиента в другой базе с тем чтобы данные о контрагенте так же были доступны в базе со счетами.
2. Помимо синхронизации первичных данных, может возникнуть необходимость построения сводного отчета по данным из нескольких баз, что тоже потребует обращения к внешним данным в online режиме.
Вариант автоматизации данного процесса с использованием файлов обмена, потребует подключения обработчика ожиданий, что сможет обеспечить обмен данными только с установленной задержкой времени обмена, кроме того любая обработка ожидания будет не эффективно использовать машинное время.
Обращение к Web сервисам, возможно при возникновении любых событий (ПриЗаписи, ПриПроведении, при нажатии кнопки и т.д.). при этом не возникнет ни какой задержки реакции информационной базы к которой происходит обращение, (в отличие от запуска еще одного приложения 1с в качестве com объекта).
Итак рассмотрим вариант реализации синхронизации элементов справочников, начнем с наиболее простого со справочника "Товары" в базах "Продажи" и "Закупки". Синхронизация для начала будет односторонней, предположим что перечень товаров заводится в базе "Продажи", а в "Закупки" он передается.

Что нам потребуется для того чтобы задача возникла и могла быть решена.
1. Сервер 1с, с установленной web компонентой;
2. веб-сервер (например IIS 6.0);
3. Две или более конфигурации учетных систем.

Что нам потребуется для решения задачи.
1. Создадим в базе "Закупки" Web-сервис "Синхронизация", и добавим ему Операцию "СинхронизироватьТовар", со строковыми параметрами.
1. "GuidТовара" - сюда будем передавать уникальный идентификатор товара присвоенный в базе Продаж.
2. "GuidРодителя" - уникальный идентификатор родителя данного товара.
3. "стрСтруктураРеквизитов" - Структура реквизитов товара в виде примитивных типов (число,строка,дата,булево) преобразованная в строку.
4. "этоГруппа" - реквизит котрый позволит нам не раскрывая всей структуры реквизитов товара узнатья явлется ли товар группой и соответственно его обработать.
5. "стрТаблицаЕденицИзмерения" - Таблица содержащая описание доступных единиц измерения для товара
title
title

Далее потребуется опубликовать данный сервис на веб сервере. для этого нужно будет создать текстовый файл "wssinhron.1cws", в каталоге сайта опубликованном на веб сервере. Библиотека wsisapi.dll, должна быть подключена. Проще всего корректную настройку работы веб сервера с 1с можно провести опубликовав веб приложение через конфигуратор Администрирование->"Публикация на веб сервере". Единственным минусом является, то что в версии 8.2 файлы веб сервисов *.1cws, сами не создаются. Возможно просто мне не хватает знаний по этому вопросу но для публикации веб сервисов я пользуюсь блокнотом.
Также следует учесть что на серверах 64x следует использовать wsisapi.dll из поставки 1с 64x, даже если сам сервер 1с у вас 86x.
Итак создаем файл "wssinhron.1cws" с текстом.

{Название вашего сервера 1с}";Ref="{Назваение базы. у нас это "Market"}";"/>

Далее перейдем в модуль обработки нашего Сервиса, для наглядности я приведу пример кода своей разработки
Код 1C v 8.2 УП
 //стрТаблицаЕдиницИзмерения - таблица в строке с колонками.
//GUIDЕдиницы
//Базовая - булево
//Коэффициент
//ЕдиницаИзмерения - код классификатора Единиц измерения.
//Утверждено - булево
//******************************
//ТаблицаГабаритов С колонками
//ВидУпаковки (строковое значение)
//Длина
//ширина
//высота
//объем
//ОбъемныйВес
//Вес
//ФормаОснования
//ВесБрутто
//*****************************

//стрСтруктураРеквизитов - структура с праметрами
//Наименование
//код
//ПометкаУдаления
//ВидТовара - идентификатор перечисления
//GUIDПроизводителя - GUID производителя
//СтавкаНДС - число ставка
//Жив - булево
Функция СинхронизироватьТовар(GUIDтовара, GUIDродителя, этоГруппа, Уровень, стрСтруктураРеквизитов, стрТаблицаЕдиницИзмерения,стрТаблицаТНВЭД)
Попытка
СтруктураРеквизитов = ЗначениеИзСтрокиВнутр(стрСтруктураРеквизитов);
ТоварСсылка = Справочники.Товары.НайтиПоРеквизиту("GUIDтовара",СокрЛП(GUIDтовара));
Если СокрЛП(GUIDродителя)<>"" тогда
ТоварРодитель = Справочники.Товары.НайтиПоРеквизиту("GUIDтовара",СокрЛП(GUIDродителя));
иначе
ТоварРодитель = Справочники.Товары.ПустаяСсылка();
КонецЕсли;

Если ТоварРодитель.Пустая() и Уровень<>"0" тогда
Если СтруктураРеквизитов.ПометкаУдаления тогда
Возврат "ОК";
КонецЕсли;
возврат "0 Не найден родитель товара";
КонецЕсли;
Если СокрЛП(GUIDтовара) = "" тогда
возврат "0 Не верный ГУИД товара";
КонецЕсли;
//заполним реквизиты
Если ТоварСсылка.Пустая() тогда
ТоварСсылка = Справочники.Товары.НайтиПоКоду(СтруктураРеквизитов.Код);
КонецЕсли;
Если ТоварСсылка.Пустая() тогда

Если этоГруппа="1" тогда
ТоварОбъект = Справочники.Товары.СоздатьГруппу();
иначе
ТоварОбъект = Справочники.Товары.СоздатьЭлемент();
КонецЕсли;
ТоварОбъект.GUIDтовара = GUIDтовара;
иначе
ТоварОбъект = ТоварСсылка.ПолучитьОбъект();
ТоварОбъект.GUIDтовара = GUIDтовара;
КонецЕсли;
ТоварОбъект.Родитель = ТоварРодитель;

ТоварОбъект.Наименование = СтруктураРеквизитов.Наименование;

ТоварОбъект.Код = СтруктураРеквизитов.Код;
.....................
Если этоГруппа="1" тогда
иначе
Если СтруктураРеквизитов.менеджер <> "" тогда
......................
КонецЕсли;
//
Если ТоварОбъект.Производитель.Пустая() тогда
Если СтруктураРеквизитов.Производитель<>"" тогда
ТекПроизводитель = справочники.Производители.НайтиПоНаименованию(СтруктураРеквизитов.Производитель);
Если ТекПроизводитель.Пустая() тогда
НовПроизводитель = Справочники.Производители.СоздатьЭлемент();
иначе
НовПроизводитель = ТекПроизводитель.ПолучитьОбъект();
КонецЕсли;
НовПроизводитель.GUID = СтруктураРеквизитов.GUIDПроизводителя;
НовПроизводитель.Наименование = СтруктураРеквизитов.Производитель;
НовПроизводитель.Записать();
ТоварОбъект.Производитель = НовПроизводитель.ссылка;
КонецЕсли;
КонецЕсли;
ТоварОбъект.СтавкаНДС = Справочники.СтавкиНДС.НайтиПоНаименованию(СтруктураРеквизитов.СтавкаНДС,Истина);

КонецЕсли;

ТоварОбъект.Записать();
ТоварОбъект.УстановитьПометкуУдаления(СтруктураРеквизитов.ПометкаУдаления,Ложь);
ТоварСсылка = ТоварОбъект.Ссылка;
ТоварОбъект = Null;

//Синхронизируем Единицы измерения
ТаблицаЕдиниц = ЗначениеИзСтрокиВнутр(стрТаблицаЕдиницИзмерения);
Для каждого строка из ТаблицаЕдиниц цикл
ЕдиницаСсылка = Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("GUIDЕдиницы",строка.GUIDЕдиницы);
Если не ЕдиницаСсылка.Пустая() тогда
ЕдиницаОбъект = ЕдиницаСсылка.ПолучитьОбъект();
ЕдиницаОбъект.УстановитьПометкуУдаления(строка.ПометкаУдаления,Ложь);
иначе
Если строка.ПометкаУдаления тогда
продолжить;
КонецЕсли;
ЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
ЕдиницаОбъект.GUIDЕдиницы = строка.GUIDЕдиницы;
КонецЕсли;

ЕдиницаОбъект.Код = строка.Код;
ЕдиницаОбъект.Наименование = строка.Наименование;
....................

ЕдиницаОбъект.Габариты.Очистить();
ТаблицаГабаритов = ЗначениеИзСтрокиВнутр(строка.ТаблицаГабаритов);
Для каждого строкаГабаритов из ТаблицаГабаритов цикл
НовСтрока = ЕдиницаОбъект.Габариты.Добавить();
............................
НовСтрока.Примечание = строкаГабаритов.Примечание;
КонецЦикла;
ЕдиницаОбъект.Записать();
Если строка.Базовая тогда
ТоварОбъект = ТоварСсылка.ПолучитьОбъект();
ТоварОбъект.БазоваяЕдиницаИзмерения = ЕдиницаОбъект.Ссылка;
ТоварОбъект.Записать();
КонецЕсли;
КонецЦикла;

ТоварОбъект = ТоварСсылка.ПолучитьОбъект();
ТоварОбъект.ВремяСинхронизации = ТекущаяДата();
ТоварОбъект.Синхронизирован = истина;
ТоварОбъект.Записать();
исключение
//в случае возникновение ошибки вывод результата облегчит поиск причины.
Возврат ОписаниеОшибки();
КонецПопытки;
//Если все прошло успешно сообщим методу вызвашему веб сервис об успешном выполнении.
Возврат "ОК";
КонецФункции


Теперь, как вызвать веб сервис не зациклив при этом систему.
в нашем справонике "Товары" в базах "Продажи" и "Закупки" нам потребуются служебные реквизиты.
1. "GUIDтовара" - строковый реквизит (50)
2. "ВремяСинхронизации" - Реквизит с типом Дата и Время
3. "Синхронизирован" - тип булево.


В модуль объекта Справочника добавим предопределенные обработчики событий "ПередЗаписью()", "ПриЗаписи()" функцию "Синхронизация()" и общую переменную "передавать", и под текстом модуля присвоим этой переменной значение Истина.
Перем передавать Экспорт;
Процедура ПередЗаписью(Отказ)
Процедура ПриЗаписи(Отказ)
Функция Синхронизация()
передавать = истина;

Таким образом получится что при любой инициализации модуля наша переменная всегда имеет значение истина.
Рассмотрим наши процедуры:
Код 1C v 8.2 УП
 Процедура ПередЗаписью(Отказ)
#Если не ВнешнееСоединение тогда
//На случай двустороннего обмена данными, необходимо ограничить возможность вызова процедур синхронизации при записи спарвника из режима внешнего соединения.
Если передавать = истина тогда
Синхронизирован = Ложь;
КонецЕсли;
#КонецЕсли
КонецПроцедуры

Процедура ПриЗаписи(Отказ)
#Если не ВнешнееСоединение тогда
Если Константы.СинхронизироватьБазы.Получить() и передавать тогда
Синхронизация();
КонецЕсли;
#КонецЕсли
КонецПроцедуры

Функция Синхронизация()
GUIDтовара = СокрЛП(ссылка.УникальныйИдентификатор());
Если ссылка.Уровень()>0 тогда
GUIDродителя = СокрЛП(ссылка.Родитель.УникальныйИдентификатор());
Уровень = ссылка.Уровень()
иначе
GUIDродителя = "";
Уровень = "0";
КонецЕсли;
Если ЭтоГруппа тогда
СтрэтоГруппа = "1";
иначе
СтрэтоГруппа = "0";
КонецЕсли;
СтруктураРеквизитов = Новый Структура;
//заполним структуру параметров которые мы бы хотели передать в базу приемник.

СтруктураРеквизитов.Вставить("Наименование",Наименование);
СтруктураРеквизитов.Вставить("код",код);
....................
Если не ЭтоГруппа тогда
Если ОсновнойПоставщик.Пустая() тогда
......................
иначе
.....................
КонецЕсли;

КонецЕсли;

стрСтруктураРеквизитов = ЗначениеВСтрокуВнутр(СтруктураРеквизитов);

ТаблицаЕдиницИзмерения = Новый ТаблицаЗначений;
//GUIDЕдиницы
//Базовая - булево
//Коэффициент
//ЕдиницаИзмерения - код классификатора Единиц измерения.
//Утверждено - булево
//ТаблицаГабаритов

ТаблицаЕдиницИзмерения.Колонки.Добавить("Наименование");
ТаблицаЕдиницИзмерения.Колонки.Добавить("Код");
....................................
Выборка = Справочники.ЕдиницыИзмерения.Выбрать(,ссылка);
Пока Выборка.Следующий() цикл
НовСтрока = ТаблицаЕдиницИзмерения.Добавить();
НовСтрока.Наименование = Выборка.Наименование;
НовСтрока.Код = Выборка.Код;
..........................
ТаблицаГабаритов = Новый ТаблицаЗначений;
Для каждого колонка из Выборка.Габариты.Выгрузить().Колонки цикл
ТаблицаГабаритов.Колонки.Добавить(колонка.Имя);
КонецЦикла;
Для каждого строка из Выборка.Габариты цикл
НовСтрока1 = ТаблицаГабаритов.Добавить();
Для каждого колонка из ТаблицаГабаритов.Колонки цикл
НовСтрока1[колонка.Имя] = строка[колонка.Имя];
КонецЦикла;
КонецЦикла;

НовСтрока.ТаблицаГабаритов = ЗначениеВСтрокуВнутр(ТаблицаГабаритов);
КонецЦикла;
// т.к. наш вебсервис принимает в себя только строковые параметры, преобразуем наши таблицы в строки.
стрТаблицаЕдиницИзмерения = ЗначениеВСтрокуВнутр(ТаблицаЕдиницИзмерения);

есть = Ложь;
колПопыток = 0;
Пока не Есть и колПопытокцикл
Попытка
Определение = Новый WSОпределения(Константы.WebАдресМаркетинга.Получить()+"wssinhron.1cws"+"?wsdl",ПараметрыСеанса.Пользователь.Код,ПараметрыСеанса.Пользователь.ПарольЗакупок);
Прокси = Новый WSПрокси(Определение, "www.market-sinhron.gor", "Синхронизация", "СинхронизацияSoap");
Прокси.Пароль = ПараметрыСеанса.Пользователь.ПарольЗакупок;
Прокси.Пользователь = ПараметрыСеанса.Пользователь.Код;
Результат = Прокси.СинхронизироватьТовар(GUIDтовара, GUIDродителя, СтрЭтоГруппа, Уровень, стрСтруктураРеквизитов, стрТаблицаЕдиницИзмерения, стрТаблицаТНВЭД);
Определение = Null;
Прокси = Null;
есть = Истина;
исключение
колПопыток = колПопыток+1;
Определение = Null;
Прокси = Null;
КонецПопытки;
КонецЦикла;
Если колПопыток=100 тогда
#Если Клиент тогда
сообщить(ОписаниеОшибки());
Предупреждение("Ошибка синхронизации. отсутствует подключение.");
#КонецЕсли
КонецЕсли;
передавать = ложь;
сообщить(Результат);
Если Лев(Результат,2)="ОК" тогда
Синхронизирован = Истина;
ВремяСинхронизации = ТекущаяДата();
Записать();
КонецЕсли;

Если СокрЛП(Результат)="0 Не найден родитель товара" тогда
#Если Клиент тогда
Сообщить("вызов синхронизации родителя");
#КонецЕсли
ОбъектРодитель = родитель.ПолучитьОбъект();
ОбъектРодитель.Записать();
Записать();
КонецЕсли;

КонецФункции


Таким образом остается добавить в событие формы элемента "ПриЗаписи()"
Код 1C v 8.2 УП
 передавать = истина;
Синхронизация();

И мы сможем записывать наш элемент сколько угодно раз не вызывая зацикливания.
Для варианта двусторонней синхронизации, (когда элемент справочника может редактироваться в обоих базах) нам потребуется скопировать наш веб сервис из базы закупок в базу продаж переименовав имя файла публикации и URI пространство имен и внести соответствующие изменения в вызов веб сервиса из базы продаж в базу закупок и опубликовать его.
Важно: При успешном срабатывание вызванного сервиса из базы "Продажи", в качестве результата работы должен быть возвращен уникальный идентификатор элемента справочника из базы "Продажи". Данный результат необходимо будет присвоить соответсвующиму реквизиту справочника из базы закупок.
Аналогично приведенному примеру можно синхронизировать данные любого справочника или документа.
Построение сводных отчетов
Для получения сводного отчета нам также потребуется вызов веб сервиса из какой - либо базы. Данный веб сервис должен будет возвращать преобразованною в строку, таблицу с данными которые мы хотим использовать в нашем отчете (Например таблицу содержащую "Код товара" и "Актуальную цену поставщика на данный товар"). Далее можно преобразовать эту строку в таблицу и использовать в качестве вложенной временной таблицы любом запросе к базе "Продажи" с соединением по Коду. Исключением является использование данной таблицы в Построителе отчетов, для случая построителя нам понадобится создание, дополнительного справочника с предопределенным элементом и табличной частью, с реквизитами соответствующими полям таблицы.
Автор: allert73
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 14877
 +7 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.