helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как сформировать отчет при открытии?

Проще всего сделать это путем передачи параметра в отчет:
Код 1C v 8.2 УП
 &НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрВыполненияКоманды)
ПараметрФормы = Новый Структура("СформироватьПриОткрытии", Истина);
ОткрытьФорму(
"Отчет.Материалы.Форма",
ПараметрыФормы,
ПараметрВыполненияКоманды.Источник,
ПараметрВыполненияКоманды.Уникальность,
ПараметрВыполненияКоманды.Окно
);
КонецПроцедуры


Но можно сделать это и самостоятельно из кода управляемой формы отчета:
Код 1C v 8.2 УП
 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
АвтоОтображениеСостояния = РежимАвтоОтображенияСостояния.НеОтображать;
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
СформироватьОтчетНаСервере();
КонецПроцедуры

&НаСервере
Процедура СформироватьОтчетНаСервере()
ЭтотОтчет = РеквизитФормыВЗначение("Отчет");
ЭтотОтчет.СкомпоноватьРезультат(Результат);
КонецПроцедуры
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 5383
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.