helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Работа с контактной информацией в типовых конфигурациях

Код 1C v 8.х
 // Исправляем значения Контактной Информации контрагента в Регистре сведений
Функция ОчиститьEmail(
Контрагент,
ТипКонтактнойИнформации,
ВидКонтактнойИнформации,
Представление
)

// #1 Создаем набор записей
НаборЗаписей = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();

// #2 Отбираем (по измерениям)
НаборЗаписей.Отбор.Объект.Установить(Контрагент);
НаборЗаписей.Отбор.Тип.Установить(ТипКонтактнойИнформации);
НаборЗаписей.Отбор.Вид.Установить(ВидКонтактнойИнформации);

// #3 Читаем набор записей
НаборЗаписей.Прочитать();

// #4 редактируем в цикле каждую запись из набора
Для каждого СтрНабЗап Из НаборЗаписей Цикл

СтрНабЗап.Представление = "";

сообщить("" + Контрагент + " | "
+ ТипКонтактнойИнформации + " | "
+ ВидКонтактнойИнформации + " | "
+ Представление + " -> " + СтрНабЗап.Представление + " [Ok!]");

КонецЦикла;

// #5 Сохраняем набор записей
НаборЗаписей.Записать();

КонецФункции

// Получить таблицу значений
// Записи из Регистра Сведений КонтактнаяИнформация с некорректными Email
функция ПолучитьТЗ()

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1000000
| КонтактнаяИнформация.Объект,
| КонтактнаяИнформация.Тип,
| КонтактнаяИнформация.Вид,
| КонтактнаяИнформация.Представление,
| (ВЫРАЗИТЬ(КонтактнаяИнформация.Представление КАК СТРОКА(1000))) как стрПредставление
|ИЗ
| РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
|ГДЕ
| КонтактнаяИнформация.Тип = &Тип
| //И КонтактнаяИнформация.Вид = &Вид
| И (ВЫРАЗИТЬ(КонтактнаяИнформация.Представление КАК СТРОКА(1000))) <> &ПустоеЗначение
| И НЕ КонтактнаяИнформация.Представление ПОДОБНО &ШаблонEmail";

//Параметры запроса:

// Типы контактной информации
Запрос.УстановитьПараметр("Тип",Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты);

// пустая строка
Запрос.УстановитьПараметр("ПустоеЗначение","");// Строка

// критерий отбора для примера простой - строка содержит символ "@" - значит это почта
Запрос.УстановитьПараметр("ШаблонEmail","%@%");// Строка
Результат = Запрос.Выполнить();

//Выборка = Результат.Выбрать();

// результат запроса выгрузить в
// таблицу значений
ПлохиеEmailТЗ = Результат.Выгрузить();

Возврат ПлохиеEmailТЗ;
КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 6293
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
rphost занимает память и грузит процессор 12
У многих возникают проблемы с rphost.exe, разного вида: rphost занимает всю память rphost грузит процессор rphost жрет память причем 1С даже на запущена, а в диспетчере следующее: ежеминутно расчет на 2-3 мегабайта. Как быть и...
Документ "Корректировка записей регистров" - Как программно создать и заполнить? 2
Документ «Корректировка записей регистров» в типовых конфигурациях 1С предназначен для ручной корректировки записей регистров накопления, зависимых регистров сведений и регистров бухгалтерии. Типичные ситуации, в...
Документ "Операция" - Как программно создать и заполнить? 6
В бухгалтерских подсистемах типовых конфигураций есть всем известный документ «Операция». Бухгалтерам не приходится долго объяснять, как им пользоваться. Все по-бухгалтерски просто и лаконично: счет дебета, счет...
Загрузить данные в 1с из текстового файла с разделителями 1
В этой статье я расскажу, как загружать данные в 1с 8 из простейших текстовых файлов с разделителями. Обычно они имеют расширение csv (Comma-Separated Values). Т. е. название подразумевает, что в каждой строке такого текстового файла...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.