helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как запретить создание документа копированием?

Бывает, нужно программно запретить копирование документа, в данной статье несколько способов реализации этого:

Код 1C v 8.2 УП
 Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

    Если НЕ Параметры.ЗначениеКопирования.Пустая() Тогда
        Отказ = Истина; СтандартнаяОбработка = Ложь;
    КонецЕсли;
КонецПроцедуры

В перед открытием

Код 1C v 8.х
 Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Если ЭтоНовый() Тогда // если объект новый

Если ЗначениеЗаполнено(ПараметрОбъектКопирования) Тогда // и существует объект копирования
Если ПараметрОбъектКопирования.Дата < Дата("20100101000000") Тогда // и условие запрета выполнено
Отказ = Истина; // Тада катись "шарик" лесом
Сообщить("Копирование документов заданного периода запрещено. Операция прервана");
КонецЕсли;
КонецЕсли;

КонецЕсли;

КонецПроцедуры

// ИЛИ

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка) 
Если ЭтаФорма.ПараметрОбъектКопирования = Неопределено Тогда 
/// 
Иначе 
Отказ = Истина; 
КонецЕсли; 
КонецПроцедуры

запретить в форме Списка  или Журнала в событии "перед началом добавления".

Код 1C v 8.х
 Процедура ДокументСписокПередНачаломДобавления(Элемент, Отказ, Копирование)
Если копирование = истина тогда
отказ = Истина.
КонецЕсли;

КонецПроцедуры
Разместил:   Версии: | 8.2 УП | 8.3 |  Дата:   Прочитано: 7312
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.