helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Сбилась нумерация после обновления Бухгалтерии на версию 3.0

После обновления бухгалтерии 2.0 на 3.0 нумерация документов начинается заново, что делать и как исправить? 

В бухгалтерии редакции 3.0 изменен способ нумерации документов по сравнению с редакцией 2.0.

Для правильной нумерации документов необходимо изменить номер первого создаваемого документа каждого вида так, чтобы он продолжал нумерацию из старой версии.

При этом номера документов, перенесенных из редакции 2.0, в печатных формах будут отображаться правильно.

Например, последний номер документа «Реализация товаров и услуг» был 00000000131.

После обновления на редакцию 3.0 первый введенный документ будет иметь номер 0000-000001.

Чтобы сохранить правильную нумерацию, необходимо в этом документе изменить номер на 0000-000132.

В дальнейшем всем введенным документам «Реализация товаров, услуг» будет присваиваться правильный номер.


Если по каким-то причинам первый способ Вам не помогает, то обратитесь к программисту 1С  для настройки нумерации документов.

Ниже приведен код осуществляющий свою нумерацию документов

Код 1C v 8.2 УП
 // Mortal - не претендую на красоту решения, сделал так: //добавил общий модуль mortalАвтонумерация, в котором 1 функция  Функция ПолучитьНомер(Ссылка) Экспорт     ДокИмя = Ссылка.Метаданные().Имя;     Запрос = Новый Запрос;     Запрос.Текст =       "ВЫБРАТЬ ПЕРВЫЕ 1    |    " + ДокИмя + ".Ссылка,    |    " + ДокИмя + ".Дата,    |    " + ДокИмя + ".Номер КАК Номер    |ИЗ    |    Документ." + ДокИмя + " КАК " + ДокИмя + "    |ГДЕ    |    " + ДокИмя + ".Дата МЕЖДУ &ДатаНачала И &ДатаКонца	|    И " + ДокИмя + ".Ссылка <> &ЭтотОбъект    |    И ПОДСТРОКА(" + ДокИмя + ".Номер, 1, 5) <> ""-""    |    И ПОДСТРОКА(" + ДокИмя + ".Номер, 1, 1) = ""0""    |    |УПОРЯДОЧИТЬ ПО    |    Номер УБЫВ";         Запрос.УстановитьПараметр("ДатаНачала", '20130101000000');       	  Запрос.УстановитьПараметр("ДатаКонца",  '20131231235959');        	  Запрос.УстановитьПараметр("ЭтотОбъект", Ссылка);    Результат = Запрос.Выполнить();    Выборка = Результат.Выбрать();    Выборка.Следующий();                                       НомерЧислом = Число(Прав(Выборка.Номер,6));    НовыйНомерСтрокой = Формат((НомерЧислом + 1),"ЧГ=0");    Если СтрДлина(НовыйНомерСтрокой) = 1 Тогда        НовыйНомерСтрокой = ("0000000000" + НовыйНомерСтрокой);    ИначеЕсли СтрДлина(НовыйНомерСтрокой) = 2 Тогда        НовыйНомерСтрокой = ("000000000" + НовыйНомерСтрокой);    ИначеЕсли СтрДлина(НовыйНомерСтрокой) = 3 Тогда        НовыйНомерСтрокой = ("00000000" + НовыйНомерСтрокой);    ИначеЕсли СтрДлина(НовыйНомерСтрокой) = 4 Тогда        НовыйНомерСтрокой = ("0000000" + НовыйНомерСтрокой);    ИначеЕсли СтрДлина(НовыйНомерСтрокой) = 5 Тогда        НовыйНомерСтрокой = ("000000" + НовыйНомерСтрокой);    КонецЕсли;        Возврат(НовыйНомерСтрокой);        КонецФункции// в модуле объекта нужных документов (для которых обязательна сквозная нумерация до конца года) добавил //mortal temp+Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)        Если ЭтотОбъект.ЭтоНовый() Тогда        Если ЭтотОбъект.Дата <= '20140101000000' И ТекущаяДата() <= '20140101000000' Тогда            ЭтотОбъект.Номер = mortalАвтонумерация.ПолучитьНомер(ЭтотОбъект.Ссылка);            КонецЕсли;    КонецЕсли;КонецПроцедуры//mortal temp-   
Разместил:   Версии: | 8.2 УП | 8.3 |  Дата:   Прочитано: 5268
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.