helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Получить список Справочников конфигурации

Код 1C v 8.2 УП
 &НаКлиенте
Процедура ПоКнопкеЧтениеИзМетаданных(Команда)
// Вставить содержимое обработчика.
Перем СписокСправочников;

СписокСправочников = Новый СписокЗначений;
СписокСправочников = СправочникиИзМетаданных();
Для Сч = 0 По СписокСправочников.Количество() - 1 Цикл
Сообщить(СписокСправочников.Получить(Сч))
КонецЦикла;

КонецПроцедуры

&НаСервере
Функция СправочникиИзМетаданных()

Перем СписокСправочников, СправочникИзМетаданных;
СписокСправочников = Новый СписокЗначений;
Для Каждого СправочникИзМетаданных Из Метаданные.Справочники Цикл
СписокСправочников.Добавить(СправочникИзМетаданных.Имя);
КонецЦикла;

Возврат СписокСправочников;

КонецФункции



Код 1C v 8.х
 //ЭлементыФормы.ОбъектПоиска - Поле Выбора на форме
СписокВыбора = ЭлементыФормы.ОбъектПоиска.СписокВыбора;
Для Каждого Справочник Из Метаданные.Справочники Цикл
//Проверим, есть ли права на просмотр? Да- добавляем, Нет - пропускаем
Если ПравоДоступа("Просмотр", Справочник) Тогда
ИмяСправочника = Справочник.Синоним;
Если ИмяСправочника = "" Тогда
ИмяСправочника = Справочник.Имя;
КонецЕсли;
Структура = Новый Структура;
Структура.Вставить("Тип", "Справочник");
Структура.Вставить("Объект", Справочник);
СписокВыбора.Добавить(Структура, ИмяСправочника, ,ЭлементыФормы.КартинкаСправочника.Картинка);
КонецЕсли;
КонецЦикла;



Код 1C v 7.x
 	//Выведем список всех справочников в окно сообщений
Для Индекс=1 По Метаданные.Справочник() Цикл
Значение = Метаданные.Справочник(Индекс).Идентификатор;
Представление = Метаданные.Справочник(Индекс).Представление();
Комментарий = Метаданные.Справочник(Индекс).Комментарий;
Сообщить(Значение+" "+Представление+" "+Комментарий);
КонецЦикла;
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 19363
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.