helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Открытие, перемещение и загрузка файла

Пример обработки загрузки данных на управляемой форме, с определением необходимости передачи файла на сервер:
Код 1C v 8.2 УП
 &НаКлиенте
Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Фильтр = "*.xml|*.xml";
Если Диалог.Выбрать() Тогда
Объект.ИмяФайла = Диалог.ПолноеИмяФайла;
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ИмяФайлаОткрытие(Элемент, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;
ЗапуститьПриложение(Объект.ИмяФайла);

КонецПроцедуры

&НаКлиенте
Процедура Загрузить(Команда)

СтрокаСоединения = СтрокаСоединенияИнформационнойБазы();

ws = НСтр(СтрокаСоединения, "ws");
ИмяСервера = НСтр(СтрокаСоединения, "Srvr");
Если ИмяСервера = "" Тогда
Если ws = "" Тогда
ПередачаФайлаНаСервер = Ложь;
Иначе
ПередачаФайлаНаСервер = Истина;
КонецЕсли;
Иначе
ПередачаФайлаНаСервер = (ИмяКомпьютера() <> ИмяСервера);
КонецЕсли;

Если ПередачаФайлаНаСервер Тогда
ПоместитьФайл(АдресХранилища, Объект.ИмяФайла,, Ложь, УникальныйИдентификатор);
КонецЕсли;

ЗагрузитьСервер();

КонецПроцедуры

&НаСервере
Процедура ЗагрузитьСервер()

ЧтениеXML = Новый ЧтениеXML;

Если ПередачаФайлаНаСервер Тогда
ИмяВременногоФайла = ПолучитьИмяВременногоФайла("xml");

ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресХранилища);
ДвоичныеДанные.Записать(ИмяВременногоФайла);
ЧтениеXML.ОткрытьФайл(ИмяВременногоФайла);
Иначе
ЧтениеXML.ОткрытьФайл(Объект.ИмяФайла);
КонецЕсли;

ОбъектXDTO = ФабрикаXDTO.ПрочитатьXML(ЧтениеXML);
ЧтениеXML.Закрыть();
/// Код загрузки
Сообщить("Загрузка завершена");
КонецПроцедуры
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 11885
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.