helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как из строки Представления Документа получить его Номер и Дату?

Код 1C v 8.х
 // Функция преобразовывает строку
// вида: "Введен на основании: Счет на оплату № 000415 от 30 июня 2008 г."
// и возвращает массив содержащий название документа, номер и дату
Функция РазбитьСтрокуДокументаНаНомерИДату(Стр)
Симв1 = Найти(Стр,":");
Симв2 = Найти(Стр,"№");
Симв3 = Найти(Стр,"от");
РезМассив = Новый Массив;
РезМассив.Добавить(СокрЛП(Сред(Стр,Симв1+1, Симв2-Симв1-1)));
РезМассив.Добавить(СокрЛП(Сред(Стр,Симв2+1, Симв3-Симв2-1)));
РезМассив.Добавить(СокрЛП(Сред(Стр,Симв3+2, СтрДлина(Стр)-Симв3)));
Возврат РезМассив;
КонецФункции

//Пример обращения
Реквизит1 = "Введен на основании: Счет на оплату № 000415 от 30 июня 2008 г.";
МассивСДанными = РазбитьСтрокуДокументаНаНомерИДату(Реквизит1);
Сообщить("Документ - "+МассивСДанными[0]);
Сообщить("Номер - "+МассивСДанными[1]);
Сообщить("Дата - "+МассивСДанными[2]);

// Результат Будет
// Документ - Счет на оплату
// Номер - 000415
// Дата - 30 июня 2008 г.



Код 1C v 7.x
  // Функция преобразовавает строку
// вида: "Введен на основании: Счет на оплату № 000415 от 30 июня 2008 г."
// и возвращает массив содержащий название документа, номер и дату
Функция РазбитьСтрокуДокументаНаНомерИДату(Стр)
Симв1 = Найти(Стр,":");
Симв2 = Найти(Стр,"№");
Симв3 = Найти(Стр,"от");
Список = СоздатьОбъект("СписокЗначений");
Список.ДобавитьЗначение(СокрЛП(Сред(Стр,Симв1+1, Симв2-Симв1-1)));
Список.ДобавитьЗначение(СокрЛП(Сред(Стр,Симв2+1, Симв3-Симв2-1)));
Список.ДобавитьЗначение(СокрЛП(Сред(Стр,Симв3+2, СтрДлина(Стр)-Симв3)));
Возврат Список;
КонецФункции


//*******************************************
Процедура Сформировать()
Реквизит1 = "Введен на основании: Счет на оплату № 000415 от 30 июня 2008 г.";
СпЗсДанными = РазбитьСтрокуДокументаНаНомерИДату(Реквизит1);
Сообщить("Документ - "+ СпЗсДанными.ПолучитьЗначение(1));
Сообщить("Номер - "+ СпЗсДанными.ПолучитьЗначение(2));
Сообщить("Дата - "+ СпЗсДанными.ПолучитьЗначение(3));
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 17000
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
В учетной политике не указан вид тарифа страховых взносов. Как указать? 0
Создайте новую запись учетной политики с начала года - Например 01.01.2013 В учетной смотрите дату начала учетной политики. Поставьте дату начала года (например 01.01.13) закладка появиться должна. Проверьте Тариф страховых...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.