helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как выполнить какую либо процедуру при открытии или закрытии программы?

В Конфигураторе, нажимаем правой кнопкой на конфигурацию:
title
Модуль управляемого приложения
Модуль управляемого приложения является аналогом модуля приложения, но используется для управляемого приложения. 1С:Предприятие 8 исполняется в режиме управляемого приложения, если запущен тонкий клиент, Веб-клиент или толстый клиент и при этом установлен режим управляемого приложения либо на всю конфигурацию, либо у конкретного пользователя. В модуле управляемого приложения могут располагаться объявления переменных, процедуры, функции и тело модуля.
Кроме того, в модуле управляемого приложения могут располагаться предопределенные процедуры ПередНачаломРаботыСистемы, ПриНачалеРаботыСистемы, ПередЗавершениемРаботыСистемы, ПриЗавершенииРаботыСистемы, ОбработкаВнешнегоСобытия. Все процедуры и функции отрабатывают на клиенте. В процедурах и функциях модуля управляемого приложения доступны экспортные процедуры и функции общих модулей управляемого клиента, а также общих неглобальных серверных модулей. Процедуры, функции и переменные модуля управляемого приложения доступны из клиентской части модулей форм и команд.

Добавляем нужный нам код, например:
Код 1C v 8.2 УП
 Процедура ПриНачалеРаботыСистемы()
Сообщить("Работайте без ошибок )");
КонецПроцедуры

При закытии программы
Код 1C v 8.2 УП
 Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Работайте без ошибок )");
КонецПроцедуры

Есть еще процедуры Перед:
Код 1C v 8.2 УП
 Процедура ПередНачаломРаботыСистемы()
//или
Процедура ПередЗавершениемРаботыСистемы()



В 1С 8.1 Конфигурация - Модуль приложения
Код 1C v 8.х
 Процедура ПриНачалеРаботыСистемы()
Сообщить("все");
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Пока!");
КонецПроцедуры


Так же есть процедуры Перед:
Код 1C v 8.х
 Процедура ПередНачаломРаботыСистемы()
//или
Процедура ПередЗавершениемРаботыСистемы()



В 1С 7.7 Конфигурация - Глобальный модуль
Код 1C v 7.x
 Процедура ПриНачалеРаботыСистемы()
Сообщить("все");
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Пока!");
КонецПроцедуры
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 17324
 0 
Распечатать
Возможно, вас также заинтересует
V82.COMConnector.1: Не найдена лицензия COM-соединением 1
При подключении из одной базы к другой через COM внезапно стала появляться следующая ошибка: «V82.COMConnector.1: Не найдена лицензия COM-соединением», хотя никаких изменений на серверах не делалось. Релиз платформы был 8.2.13....
Где находится файл лицензии 1С 9
Многие спрашивают А где хранится лицензия на 1С: Предприятие 8? или Где посмотреть лицензионный ключ в 1С? В 1С информацию о полученной лицензии можно посмотреть нажав «Справка» — «О программе» В разделе Лицензия:...
Где физически находится Журнал регистрации? 2
В файловом варианте информационной базы «1С:Предприятие 8.0» журнал регистрации располагается в каталоге информационной базы, там же, где и файл самой информационной базы. Например, если информационная база хранится в...
Горячие клавиши 1С Пользователю [ Предприятие] 0
Основные команды: Интерфейс: F6 - переключение между формами рабочего стола F10 - переход в главное меню окна Alt+1 - переход на панель Разделов Alt+2 - переход на панель Навигации Alt+3 - переход на панель Действий Alt+9 -...
Горячие клавиши 1С Разработчику [ Конфигуратор ] 20
Основные команды: Кодирование: Ctrl+Пробел - вызов подсказки Ctrl+Q - вызов шаблона Ctrl+F1 - поиск в синтакс-помощнике Ctrl + L - удалить текущую строку Alt+Shift+F - отформатировать код Исследование: F12 - ставим курсор на...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.