helpf.pro
Регистрация
 +2 
Распечатать

1С 8.3 : Внешняя печатная форма, дополнительные параметры для печати

Внешняя обработка (Печатная форма), содержащая: Необязательный реквизит «ДополнительныеПараметры» произвольного типа, которому будут передаваться дополнительные параметры примитивного типа в виде структуры.
title
Аналогично можно передать параметр во внешнюю печатную форму через реквизит «ДополнительныеПараметры».
В модуле обработки для использования этих параметров используем следующий код вида:
Код 1C v 8.х
 Если ТипЗнч(ДополнительныеПараметры) = Тип("Структура") Тогда
Если ДополнительныеПараметры.Свойство("КодФилиала") Тогда
КодФилиала = ДополнительныеПараметры.КодФилиала;
Иначе
КодФилиала="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("КодОрганизации") Тогда
КодОрганизации = ДополнительныеПараметры.КодОрганизации;
Иначе
КодОрганизации="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("ОтделениеБанка") Тогда
ОтделениеБанка = ДополнительныеПараметры.ОтделениеБанка;
Иначе
ОтделениеБанка="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("НомерДоговора") Тогда
НомерДоговора = ДополнительныеПараметры.НомерДоговора;
Иначе
НомерДоговора="";
КонецЕсли;
Если ДополнительныеПараметры.Свойство("ДатаДоговора") Тогда
ДатаДоговора = ДополнительныеПараметры.ДатаДоговора;
Иначе
ДатаДоговора="";
КонецЕсли;
КонецЕсли;


Настроим передачу параметров внешней печатной форме
Для этого создаем новый элемент справочника «Внешние обработки» и заполняем его, как показано на рисунке ниже
В табличной части открываем Параметры обработки и вводим значения параметров
title
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 39042
 +2 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 38
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 1
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже веб-узла в э
Google maps : вывод точек на карту и режим панорамы 6
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное ускорение видеокарты В Window
Битая ссылка, , Уникальный Идентификатор, GUID - Управляемые формы 2
Переделал обработки из статей Битая ссылка, Объект не найден, Уникальный Идентификатор, GUID и Поиск в базе битых ссылок - объект не найден под Управляемые формы. Скачать
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.