helpf.pro
Регистрация
 +23 
Распечатать

1С 8.3 : Как передать файл с сервера на клиент?

Код 1C v 8.2 УП
 &НаСервере
Функция ПолучитьФайл()
Двоичное=Новый ДвоичныеДанные("C:\файл.bmp");
Адрес=ПоместитьВоВременноеХранилище(Двоичное,ЭтаФорма.УникальныйИдентификатор);
Возврат Адрес
КонецФункции

&НаКлиенте
Процедура Получить()
Адрес=ПолучитьФайл();
Двоичное=ПолучитьИзВременногоХранилища(Адрес);
КонецПроцедуры


Если же необходимо файл сохранить на Клиенте на диск - тогда так:
Код 1C v 8.2 УП
 
&НаСервере
Функция ПолучитьФайл()
Двоичное=Новый ДвоичныеДанные("C:\файл.bmp");
Адрес=ПоместитьВоВременноеХранилище(Двоичное,ЭтаФорма.УникальныйИдентификатор);
Возврат Адрес
КонецФункции

&НаКлиенте
Процедура Получить()
Адрес=ПолучитьФайл();
Описание=Новый ОписаниеПередаваемогоФайла("C:\FromServer.bmp",Адрес);
МассивОписаний=Новый Массив;
МассивОписаний.Добавить(Описание);
ПолучитьФайлы(МассивОписаний,,,Ложь);
КонецПроцедуры
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 102506
 +23 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 24
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через терминал, а еще у нее свой ноутбук и
1C: Enterprise Development Tools 52
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 1
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже веб-узла в э
Google maps : вывод точек на карту и режим панорамы 9
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 2
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка получени
Посмотреть все результаты поиска похожих
Комментарии
all4cf
10.06.2024 21:36Комментарий: 1
all4cf

Актуальный вариант:

Код 1C v 8.3
 
&НаКлиенте
Процедура СкачатьФайл(Команда)
    ВыбранныеСтроки = Элементы.ТаблицаФайлы.ВыделенныеСтроки;
    Если ВыбранныеСтроки.Количество() = 0 Тогда
        Возврат;
    КонецЕсли;
    ИмяФайлов = Новый Массив();
    Для Каждого Строка Из ВыбранныеСтроки Цикл
        ТекСтрока = ТабЧастьФалы.НайтиПоИдентификатору(Строка);
        ИмяФайла = ТекСтрока.Наименование + ТекСтрока.Формат;
        ИмяФайлов.Добавить(ИмяФайла);
    КонецЦикла;
            
    ИмяФайловДляСкачивания = ПодготовитьФайлыНаСервере(ИмяФайлов);
    
    ПараметрыДиалога = Новый ПараметрыДиалогаПолученияФайлов("Выберите каталог для сохранения файлов", Истина);
    //ПараметрыАрхива = Новый ПараметрыПолученияАрхиваФайлов("files.zip", РежимПолученияАрхиваФайлов.ПолучатьАрхивВсегда); 
    НачатьПолучениеФайловССервера(ИмяФайловДляСкачивания, ПараметрыДиалога);
            
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПодготовитьФайлыНаСервере(ИмяФайлов)
    
    ИмяФайловДляСкачивания = Новый Массив();
    
    Для Каждого ИмяФайла Из ИмяФайлов Цикл
        Путь = "D:\IIS\DataBase\scan\" + ИмяФайла;
        Адрес = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(Путь));
        ИмяФайловДляСкачивания.Добавить(Новый ОписаниеПередаваемогоФайла(ИмяФайла, Адрес));
    КонецЦикла;
    
    Возврат ИмяФайловДляСкачивания;
    
КонецФункции
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.