helpf.pro
Регистрация
 0 
Распечатать

1С 8.3 : Как запретить создание документа копированием?

Бывает, нужно программно запретить копирование документа, в данной статье несколько способов реализации этого:

Код 1C v 8.2 УП
 Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

    Если НЕ Параметры.ЗначениеКопирования.Пустая() Тогда
        Отказ = Истина; СтандартнаяОбработка = Ложь;
    КонецЕсли;
КонецПроцедуры

В перед открытием

Код 1C v 8.х
 Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Если ЭтоНовый() Тогда // если объект новый

Если ЗначениеЗаполнено(ПараметрОбъектКопирования) Тогда // и существует объект копирования
Если ПараметрОбъектКопирования.Дата < Дата("20100101000000") Тогда // и условие запрета выполнено
Отказ = Истина; // Тада катись "шарик" лесом
Сообщить("Копирование документов заданного периода запрещено. Операция прервана");
КонецЕсли;
КонецЕсли;

КонецЕсли;

КонецПроцедуры

// ИЛИ

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка) 
Если ЭтаФорма.ПараметрОбъектКопирования = Неопределено Тогда 
/// 
Иначе 
Отказ = Истина; 
КонецЕсли; 
КонецПроцедуры

запретить в форме Списка  или Журнала в событии "перед началом добавления".

Код 1C v 8.х
 Процедура ДокументСписокПередНачаломДобавления(Элемент, Отказ, Копирование)
Если копирование = истина тогда
отказ = Истина.
КонецЕсли;

КонецПроцедуры
Разместил:   Версии: | 8.2 УП | 8.3 |  Дата:   Прочитано: 7327
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Автоматическая архивация баз 1С с использованием Cobian Backup и VBS скриптов 6
Клиент попросил настроить автоматическую архивацию баз 1С раз в три дня и выгрузку архивов на Dropbox и на FTP Сервер. Кроме 1С нужно архивировать папку с рабочими документами. Хочет - так хочет, делаем: Первым делом...
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное...
Ввод данных по командировкам в программе ЗУП 0
Ввод сведений о командировках в программе 1С: Зарплата и управление персоналом 8 (ред.30) осуществляется в Разделе Кадры - Все кадровые документы - Создать - Командировка Откроется документ: Ввод сведений о...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.