helpf.pro
Регистрация
 0 
Распечатать

1С 8.3 : Как проверить записан ли документ?

Перед обработкой документа необходимо проверить - записан ли документ? если Да - обработать, нет -вывести предупреждение!

Ниже код позволяющий проверить записан ли только что созданные документ:

В Такси и вообще управляемом приложении проверяется ссылка: Объект.Ссылка.Пустая()

Код 1C v 8.3
 // в Управляемом приложении
&НаКлиенте
Процедура ОбработатьДок(Отказ)
         Если не ЗначениеЗаполнено(Объект.Ссылка) тогда
            Отказ=Истина; //Докум еще не записан, т.к. ссылки нет         
    КонецЕсли;
КонецПроцедуры 
Код 1C v 8.х
 // В Обычных формах
Если ЭтоНовый() Тогда
Предупреждение("Документ должен быть записан!");
Иначе
// обрабатываем
КонецЕсли;

код, позволяющий проверить признак модифицированности ранее созданного документа:

Код 1C v 8.2 УП
 Если ЭтотОбъект.Модифицированность() Тогда
      
        Предупреждение("Документ был изменен. Для обработки его нужно записать.");
        Возврат Неопределено;     
      
    КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 8000
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Автоматическая архивация баз 1С с использованием Cobian Backup и VBS скриптов 6
Клиент попросил настроить автоматическую архивацию баз 1С раз в три дня и выгрузку архивов на Dropbox и на FTP Сервер. Кроме 1С нужно архивировать папку с рабочими документами. Хочет - так хочет, делаем: Первым делом...
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.