helpf.pro
Регистрация
 0 
Распечатать

1С 8.3 : Фоновые задания 1С, примеры работы и параллельного запуска

В рамках выполнения проекта столкнулся с интересной задачей ускорения загрузки данных из других информационных баз. Задача загрузки данных предполагала выполнение к внешней базе несвязанных между собой запросов, результаты которых помещаются в одну таблицу значений. Когда на оптимизацию запроса рука уже не поднималась, приступил к ускорению загрузки с помощью распараллеливания процессов. Отмечу, что элементы кода в данном посте приведены для клиент-серверного варианта и укрупнено для общего понимания подхода.

Что у нас в 1с Предприятии 8.2 имеется для распараллеливания & это фоновые задачи. Метод, который будет вызываться в фоновой задаче, должен быть прописан в серверном общем модуле и быть экспортным. Естественно нам понадобиться в фоновую задачу передавать и забирать значения.

В моем случае передача значений в фоновую задачу происходила через параметры. Метод ЗагрузитьИзВИБ имеет два параметра это ВходнойПараметр и АдресВХранилище. ВходнойПараметр это структура, в которую сгружаются все данные, необходимые для проведения загрузки. АдресВХранилище это адрес во временном хранилище, по которому будет передан результат загрузки. Сам код метода фонового задания выглядит так:

Код 1C v 8.х
 Процедура ЗагрузитьИзВИБ(ВходнойПараметр,АдресВХранилище) Экспорт
    //Из структуры перегоняем данные в переменные
    ТаблицаДляЗаполнения = ВходнойПараметр.ТаблицаДляЗаполнения;
    ДанныеОбъекта = ВходнойПараметр.ДанныеОбъекта;

    //Тут идет собственно загрузка данных
    ВыполнитьЗагрузку(ТаблицаДляЗаполнения,ДанныеОбъекта);

    //Возвращаем данные из фоновой задачи в хранилище
    ПоместитьВоВременноеХранилище(ТаблицаДляЗаполнения, АдресВХранилище);
КонецПроцедуры

Зачем нам в фоновую задачу передавать адрес во временном хранилище. Наша фоновая задача должна куда-то положить результат, причем так чтобы мы знали где его потом взять.

Для того чтобы запустить фоновые задачи выполняется следующий код:

Код 1C v 8.х
 МассивАдресовВХранилище = Новый Массив;
МассивЗапущенныхЗаданий = Новый Массив;
Сч = 1;
Пока Сч <= КоличествоПотоков Цикл
Ключ = Новый УникальныйИдентификатор;
ВходнойПараметр = Новый Структура;
ВходнойПараметр.Вставить("ТаблицаДляЗаполнения",ТаблицаДляЗаполнения);
ВходнойПараметр.Вставить("ДанныеОбъекта",ДанныеОбъекта);

//Подготовим адрес в хранилище
АдресВХранилище = ПоместитьВоВременноеХранилище(Неопределено);
МассивПараметров = Новый Массив;
МассивПараметров.Добавить(ВходнойПараметр);
МассивПараметров.Добавить(АдресВХранилище);
МассивАдресовВХранилище.Добавить(АдресВХранилище);

МассивЗапущенныхЗаданий.Добавить(ФоновыеЗадания.Выполнить("ОбщийМодульСервер.ЗагрузитьИзВИБ",МассивПараметров, Ключ, "Загрузка"));
Сч = Сч + 1;
КонецЦикла;

Перед запуском фоновой задачи через ФоновыеЗадания.Выполнить() мы формируем массив параметров. Значения из массива параметров переходят в метод фонового задания в качестве параметров. В МассивЗапущенныхЗаданий хранятся все фоновые задачи, которые мы запустили. Теперь надо подождать их ожидания.

ФоновыеЗадания.ОжидатьЗавершения(МассивЗапущенныхЗаданий);

После того как все задачи были завершены, можем приступить к получению из них данных. Для этого мы проходим по всем адресам в хранилище, которые хранятся в массиве МассивАдресовВХранилище. После получения результата фонового задания перегоняем его в общую таблицу.

Код 1C v 8.х
 Для Каждого ТекАдресВХранилище Из МассивАдресовВХранилище Цикл
    ТекТаблица = ПолучитьИзВременногоХранилища(ТекАдресВХранилище);


    Для Каждого ТекСтрокаДанные Из ТекТаблица Цикл
        НоваяСтрока = НашаОбщаяТаблица.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСтрока,ТекСтрокаДанные);
    КонецЦикла;
КонецЦикла;

Вопрос определения оптимального количества потоков выходит за рамки данного поста. А после получения некоторых результатов на рабочих данных пока что выходит и за рамки моего сознания ). Но если у вас есть идеи как посчитать нужное количество потоков, пишите в комментариях, с радостью почитаю.

Источник

Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 993
 0 
Распечатать
Возможно, вас также заинтересует
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное...
Где скачать классификатор ФИАС (вместо КЛАДР) для загрузки в 1С и как установить ФИАС? 2
Думаю, уже многие слышали что KLADR заменен на ФИАС (Федеральная информационная адресная система) Единой информацией из ФИАС будут обязаны пользоваться все ведомства – ГИБДД, Росреестр, ЗАГС, ФМС России и др, в...
Журнал транзакций для базы данных "db_buh" переполнен. Причина: "LOG_BACKUP". HRESULT=80040E14 1
При обновлении бухгалтерии, на этапе сохранения, получил следующую ошибку: Каталог не обнаружен v8srvr://sql/acc_main/configsave/e0666db2-45d6-49b4-a200-061c6ba7d569.6b9d6525-ee94-4e13-b73d-82d3e8e8441d по причине: Каталог не обнаружен...
Загрузка данных в 1С из PDF 1
В данной статье описан пример реализации загрузки данных накладных из PDF файлов для одного крупного Ритейла... И так у Нас есть несколько файлов в формате pdf, которые нам необходимо загрузить в 1С. Чтение PDF файлов из...
Загрузка данных из XML в 1С 8.2 0
В данном видео будут рассмотрены основные принципы загрузки данных из файлов XML в 1с Предприятие 8.2. Автор: Александр Боровой
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.