helpf.pro
Регистрация
 0 
Распечатать

1С 8.3 : Как удалить строку или очистить дерево значений

Помните, что при при удалении/очистке строки, все подчиненные строки удаляются.

Очистить дерево значений: Дерево.Строки.Очистить();

Код 1C v 8.2 УП
 &НаСервере
Процедура ОчиститьНаСервере()
   тДерево = РеквизитФормыВЗначение("Дерево");
 
   тДерево.Строки.Очистить();
 
   ЗначениеВРеквизитФормы(тДерево, "Дерево");
КонецПроцедуры

Точно также можно очистить от подчиненных элементов другую другую строку.

Удалить строку дерева значений не сложнее & нужно только знать ее индекс:

Код 1C v 8.2 УП
 &НаКлиенте
Процедура Удалить(Команда)
   УдалитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура УдалитьНаСервере()
   тДерево = РеквизитФормыВЗначение("Дерево");
 
   тДерево.Строки.Удалить(0);
 
   ЗначениеВРеквизитФормы(тДерево, "Дерево");
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 27437
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 6
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код заполнения ТЧ НаСервере П
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 41
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
Google maps : вывод точек на карту и режим панорамы 7
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора
ВКС - Высококвалифицированные специалисты - какие настройки нужно сделать ЗУП? 0
В этой статье мы вкратце расскажем - какие настройки нужно сделать ЗУП для временно пребывающих высококвалифицированных иностранных специалистов. Гражданство Откройте сотрудника и перейдите в настройки данных о Гражданстве Если сотрудник ВКС то
Выгрузка картинок из базы 1С в XML 2
В нынешнее время для электронного каталога или интернет-магазина необходимо выгружать не только информацию о цене и характеристиках товара, но и сопутствующие изображения. Хранящиеся в базе или связанные с номенклатурой изображения порой приходилось
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.